Another booring bug/issue regarding strip silence

Well, its a PITA, I lost 3 times again some work because of that. I told myself to not waste any time anymore to post bugs. But now it happened again… grrrr… I forgot again to safe before doing that because I am in a hurry.

OK.

It happens only in one situation.

Open a song with multitrack drums. Lets say 12 tracks to keep it simple. Do a lot of beat-detective quantize/editing. Bounce da sh*t out of the snippets to have solid waves again for further editing.
Never hit stop, edit fast, always in playback mode.
Select - still in playback mode - for example - a tomtrack, strip silence. Don’t safe before doing that :imp:

Everything will work, but when you hit “OK” or process or whatever that might be called in the english version… then it will freeze. Not completely - playback is still running. Meters are moving. But Nuendo is locked. You can not safe. I tried everything, because as it happened the first time I checked the backup file - to make myself clear how much time I will loose. Well, backup-file was abou 90 minutes old!!

(maybe it could be a good idea to finally implement the option to have autosafe enabled even in playback mode, because it will not safe till you hit stop. Usually I never hit stop, I am editing on the fly)

You have to kill Nuendo.exe in the taskmanager.

The strip silence feature itself works fine, just do not use it after serious editing/bouncing!

It happened to me almost all the time the last 2 days, I would say about 10 times… 8 Times of that I safed manually before strip silence, Killed Nuendo after the freeze, cursed big time, started everything again, then it worked (because now there is no undo history) … but 2 or 3 times I forgot to safe because I was in the flow.

F*CK

Damn sh*t it happened again (I safed before but killing nuendo and loading everything again is nasty)

Strange thing - there is no Nuendo.log file… I was about to check what is going on there.

Well, I am fast with Nuendo, but lately I am loosing so much time, patience and creativity… “Creativity last”… In summer I will have some offtime… I will most likely check out Pro Tools, I can’t wait for years till things are fixed…
stripsilence.JPG

Well, my intention was not to be that as well. And not post any more stuff… Becaue it does not chance something, most of the users will not step over this bug as well because they are not quantize-editing blast-beats/fast drums.

But I just lost my nerves - no joke, I found myself screaming around for 3 minutes after I lost work the last time. My stomach is fine, but my head hurts… no joke. And not kidding…

Hi Brandy,

Are you running 32bit or 64bit version of Nuendo. I too experienced some problems like you have mentioned in the 32bit version of Nuendo (they were usually always related to running out of memory and some things would just push it over the edge when working). Since switching to 64bit Nuendo (when Waves went 64bit) all of these issues have disappeared for me.

I had similar problem when using lot of real-time stretch in C6 recently. I was rough-editing preproduction tracks of a full band, so 8 tracks, one song per project - I realized that the timestretch-tool (the one with the mouse in the project) greatly improoved - it is almost phase-synced (at least ok for preprod stuff) and it is in real time, that means, no calculating time anymore…

But I had ugly crashes - runtime errors with full-freeze - I had to reset the computer… But here I checked taskmanager and I realized that the RAM went up from a few hundred MB ASAP to 3 GB and more (later in 64 bit then, in 32 bit it crashed at around 2,8GB).

Doing this in 64 bit fixed it 100%.

Well, I will check in the taskmanager how much is the RAM.

Mh, no… Ram is 1.500 in the beginning (opening the project, drums are bounced but edited drums are still on disabled tracks in the project)

I quickly qantized the full song (not taking care about music, just click and ok) - Nuendo almost freezed because of the amount of slices but RAM just 1.590 now… only 90 MB more… Maybe in 64 bit it will go away, but RAM is not the culprit.

Ok, I closed that project without saving, opened it again - because now the strip silence thing needs to be done…

FREEZE.

At about 1.6 GB Ram.

So Nuendo needs to be closed and reopened before. Not only the project.

How are you checking the memory usage?

Process of Nuendo.exe in the Taskmanager?!

Here’s a copy/paste from one of my other posts:

On 64bit windows, any 32bit process can use 32bits of address space i.e. 0x00000000 to 0xFFFFFFFF in hexadecimal, 4GB in decimal. This memory is then used when you instantiate a plug-in, when the host needs to create tracks, send control surface information etc. You will see Nuendo crashes when Nuendo runs out of 0xFFFFFFFF address space.

Don’t bother using the regular task manager to monitor memory usage as that doesn’t tell you the total amount of address space the process is using. To check memory related crashes download Process Explorer and make sure “Virtual Size” is showing. Keep Process Explorer running while using Nuendo and if a crash occurs when the Virtual Size reaches 4GB then it is memory related.

I have noticed in some more recent builds of Nuendo that sometimes the memory is not released by the plug-ins when closing the session which then requires a restart of Nuendo (rather than just the session). This gives further evidence that your problems are likely to be memory related.

Ok, I will check that! Thanks so far! Maybe it is memory-based. But if I do NOT use strip silence I can work on for hours without any issue… When I max out 32bit memory I would guess that I would ran into other kinds of problems, but I can work on, insert zillions of plugins, edit etc… I can even change between projects and restart beatdetective-editing in other songs.

Well but I agree, after closing/opening a couple of bigger projects during the day Nuendo likes to crash while loading. Maybe something is “full” then.

I don’t like those crashes because the will delete all previous made tweaks and settings Nuendo-wise, for example I have to re-select all the file-pathes when importing/exporting media, I have to re-set all the parameters in strip-silence window, all settings which are made in programm settings are away.

Maybe it could be a good idea to have future Nuendo versions immediately store/save changes/settings when they are done, not only when you close Nuendo. Because that way you will loose everything in cause of a crash.

At 1.5Gig, you are maxing out the memory on 32bit.
Alomost 100% sure that your problems relate to that.
Just for fun, fire up the 64bit version and try to do the same.


Fredo

Mh, AFAIK in Win7 64 bit I can go higher? Even with 32bit host? I was able to go to about 3 GB all the time in the past.

Well, I will check this out as well as the Memory thing, (un)fortunately I am done so far with that editing and today/tomorrow I have clients here for mixing.

The reason why I never stepped over it might be that I usually edit everything first and then the strip-silence thing (which is a mix thing) happens way later in another session. This time it was scheduled as a mix but well… I ended up editing a lot…

Quote Brandy:
Do a lot of beat-detective quantize/editing. Bounce da sh*t out of the snippets to have solid waves again for further editing.Never hit stop, edit fast, always in playback mode. Select - still in playback mode - for example - a tomtrack, strip silence. Don’t safe before doing that …


Griasdi Brandy oida Preiß

M2C…Maybe… Don’t do it, then?

Greets from Minga
Big K

Ja was in au now M2C?!

Well, it happened even when hitting stop all the time and spending very much time for that :slight_smile:

But then autosafe works and a crash is not that booring.

Häh?
:confused:

M2C - was ist das?

My 2 cents …
My humble (maybe insignificant) opinion about xy …
My thoughts about xy …

English natives??

Big K