Another problem when rendering to FLAC

Using exactly your settings, I can’t reproduce the problem.
I note a curious detail, though: when the option “Open resulting file” is unchecked (as on your dialog), the option “Bypass Master Section on resulting file” should be disabled (by WaveLab). This is not the case on your picture. Are you really using WaveLab 8.5.10?

Yes, it’s Version 8.5.10 (build 857) - 64 bit

As for the un-disabled checkbox, I’ve captured a quick screencast to show what’s happening on my PC: The checkbox always comes up enabled when the dialog is opened; only if I uncheck “Open resulting file”, the other checkbox gets grayed out.

To illustrate my problem, I’ve created another quick screencast - is there any other option I might have overlooked that will cause the sampling rate to change?

(By the way, the preview quality of Dropbox’ MP4 video files is rather bad; if you can’t see what’s happening, please download the file - that will be in full resolution)

Any ideas on this issue? I’m definitely not making this up… :cry:

Have you tried removing all insert plugins? Or forcing 48KHz (not match input stream). And then opening the result file in Wavelab. This only happens with FLAC, not Wav?

In the edit mode of Wavelab, does it also show that the rendered FLAC file is 44.1k instead of 48k, or just your dB Poweramp?

Maybe you could upload a zip of your montage and one or two songs and I could open and do a test render here to see if something is corrupted in your montage or settings somehow.

It’s very strange.

Thanks for taking the time to reply. I’m not sure what you mean by “removing insert plugins”, can you clarify?

Also, yes, the 44.1 is shown in Wavelab as well (look at the second screencast I posted), not just in Windows/dbPoweramp.

I’ll try to reproduce this with a smaller montage file/audio file and see if I can post this.

I meant remove all of the plugins in the Master Section shown in your picture. Instead of disabling or turning them off, remove all of them (the Maximizer, Peak Master, Crystal Resampler, MBiT dithering, and the Encoder Checker). Remove them.

Also instead of “Samplerate Wie Eingangsquelle” in the Audiodateiformat, make it “Samplerate 48 KHz”.

Also try rendering the same thing to WAV instead of FLAC. Does this also happen to your result WAV if you render to WAV, or only if you render to FLAC? (Does the result WAV come out 48K or 44.1K?)

OK, I’ve reproduced the problem with a small file. I’ve uploaded the WAV file (containing just audience noise for a few seconds), the .mon file I created and the resulting FLAC file to here.

The steps I took:

  • Open the WAV file in Wavelab’s file editor.
  • Choose File - Export - Create audio montage from current file
  • Check to see that it’s 48 kHz
  • Choose Render with default options (flac hq)
  • The new FLAC file opens in Wavelab and is at 44.1 kHz

Again, I made a screencast to show what I did. Can you reproduce this?

I also tried the same thing after having deleted all the plugins from the effects queue as well as from Dithering and Post Processing - no change in outcome.

Interestingly, though, I also get 44.1 kHz when I choose WAV 24 bit as output - so it’s not limited to FLAC.

And when I manually set the output sampling rate to 48000, I do get 48000 (after a stern warning that Wavelab recommends the “Use input stream” setting), but that’s not the point (I think). The point is why Wavelab appears to think that the input stream is 44.1k when it’s clearly 48k…

I used your source WAV file and test montage and I still can’t reproduce the problem. I watched the screencast but I do not know the language that you are using in Wavelab so I can’t comment on all your render settings.

Opening your montage and rendering a level 8 Flac file with my render settings attached in the screenshot produces a 48k Flac file. Also, doing your workflow of opening the 48k WAV in the edit mode, and creating a montage from the current file, and then rendering to level 8 Flac file also produces a 48k Flac file.

Here is a link to both of the rendered Flac files I made from the methods described above:

File A is direct from your montage, file B is making my own new montage from the source file in the edit mode.

Thanks for going to all that trouble. I’m quite sure that I haven’t changed any of the render settings, but of course it’s unfortunate that I can only generate a German screencast…

I’m increasingly starting to think that there must be some other setting outside of all this workflow that somehow affects the result (since it happens for FLAC and WAV), but I have no idea where to look…

Do you have another computer you can test on? Or another sound card output you can switch to for a test?

For the render settings, it sounds like you have it correct but you want to have the sample rate “match input stream”.

When you open my Flac files in Wavelab editor mode, did they show as 48k?

Maybe see if you can use my Flac 8 preset to render from:
FLAC Level 8.dat.zip (492 Bytes)

I have also tried the test.zip and cannot reproduce the problem. I’ve also checked (using MediaInfo) that the same version of libFLAC was used (1.3.0) and the only difference is the bitrate. One strange thing though is that the test.flac in the zip is 956157 bytes in size, but the one I render is only 903588, and the reason I find that strange is that one would imagine that, all things being equal, a file with a higher bitrate would be larger.

So I just listened to both the test.flac and the original test.wav, and the decoded flac (which should be lossless, i.e. no different to the original, by definition!) is louder than the wav. You have something somewhere in your render chain that is causing a difference; the reason your flac is larger is because there’s more high-frequency energy to be encoded (due to the increased level). Find out what’s causing that increase and you’ll find what’s changing your samplerate.

@MrSoundMan: During the rendering of the FLAC file in my ZIP file, the Maximizer and Peak Master plugins were active, which is why the FLAC is louder than the WAV.

However, the problem persists even if I delete those plugins from the chain. So that’s not it, unfortunately.

@JPerkinski: Your FLAC files show as 48k in Wavelab editor mode. I don’t have a different sound card or PC to try this on.

I also used your preset and still got a 44.1 kHz output file…

Well, this sounds like a very strange bug or deep problem. Unfortunately, I don’t know Windows or German well enough to help any more.

For entertainment, have you tried using the Crystal Resampler to successfully make a 96k FLAC file, or even setting the Resampler to 48k, even though you are at 48k?

@Jperkinski: The plot thickens. I have just enabled Crystal resampler, setting it to 96 KHz.

When I now click on Render, the dialog has changed spontaneously: In the File format dropdown, it now reads “Flac / Stereo / 96 000 Hz / Pegel: 8” (which is a mistranslation, by the way - “Level” doesn’t translate to “Pegel” here, because it has nothing to do with “sound intensity” but with compression efficiency; “Stufe” would be correct, but that’s incidental).

When I open the File format dialog, it looks the same as before except that “Channels” has been set to “Stereo”; “Sample Rate” is still set to use the input stream settings.

When I do the render now, the output file is still in 44.1 kHz! WTF?

I’ve got to go to work now, so I can’t test the other cases right now, but I thought you might find this interesting.

Cheers,
Tim

To add to the strangeness: Rendering definitely takes a lot longer when setting Crystal resampler to, say, 384 kHz than when setting it to 48 kHz or turning it off - but the resulting files are nearly identical in size, and they sound identical, but they are entirely different when doing a byte-by-byte comparison (probably the result of resampling from 384 kHz to 44.1 looks different than when it’s done from 48 to 44.1?)…

One thing you could try is resetting WaveLab to the defaults … quit WL, go to %APPDATA%\Steinberg and rename the folder “WaveLab 8.5” temporarily; when you restart WL, it will create a new folder there with the original name. Do your tests again.

To get back to your old settings, just delete the newly-created folder and rename the old one back to the original.

Huh, that did it.

I deleted the folder, restarted Wavelab and answered the “Do you want to import your Wavelab 8 settings?” question with “No” - and then everything worked as expected.

If anyone is interested, I’ve uploaded the folder with the “defective settings”, whatever they may be, to here. Thank you all for your help so far - if anyone can find out what was wrong with my installation, even better…