Another Super Amazing Unintended Anti-Feature

Thanks to a bug I just found, I get to redo a ton of work.

When using Ozone 5, I get this weird stuttering glitch at the end of files that have a musical fade out. I’m not sure where the problem is coming from because when I launch Ozone 5, the problem isn’t there, but as I change settings, it increases. My default setting has the glitch really bad. I’m trying to turn things off to eliminate the glitch but the glitch is always there to some degree except when I first launch Ozone and take it out of bypass. I first suspected it was in the dither setting of Ozone 5 which is last in my plugin chain on the montage master, but even with no dither or hard dither, it’s there.

Here’s a link to hear a clip of just the tail end of an example piece:

https://www.dropbox.com/s/xxif21sb7lgptwx/3ING-021-02.wav?v=1mci

Listen to the stuttering glitch at the end of the file, it’s not intentional. It’s only there on clips with strong musical fade outs, when it’s just air or natural sustain, it’ not there, or is not audible or problematic. I know the fade out is abrupt but it’s supposed to be that way since it’s a promo-30 for broadcast use.

It doesn’t seem to be there when I have Ozone on the original master section but when it’s on the new montage master section. it’s on the playback and the rendered file.

I can’t understand why Wavelab is always so problematic, it has it’s moments and it has potential but I’m honestly just about ready to give up on it. I did hours of work last week that must be redone because of this issue.

I can’t justify waiting a minimum of one month for this to be solved either.

Sincerely,

Your slave beta-tester that gets to stay up all night fixing files and montages and other general fucking around.

Also, even with the Ozone on the master section (not the montage master), I am getting a little blip of the tail of the last song happening again at the end of the montage before it ends. So song natural decay, one second of air, split second of audio from end of the song:

https://www.dropbox.com/s/v9txps12j4cxvad/Problem_2.wav

The blip at 53 seconds and 700ms on that file is not anywhere in the montage, it comes from nowhere, probably from Ozone somehow. None of this happened in WL7.


This happens on playback and rendering.

OSX 10.8.3
Mac Pro 2.8GHz Quad-Core
8GB Ram
64-bit

Current plugins.

Super annoying.

After trying to figure out where to even start on fixing a week’s worth of problems regarding this, I just wanted to reiterate how fucking annoying this issue is.

:smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :smiling_imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :imp: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:

Here is my Ozone 5 setting. At first launch, the issue is not there. As you tweak things, the issue gets worse.
Screen Shot 2013-05-17 at 5.03.20 PM.jpg

Why do you say WaveLab is responsible of this glitch while you are using Ozone? If you don’t use Ozone, do you get this glitch?

I assumed that would be your response. I assume it’s WL8 that is problem because the issue didn’t happen in WL7 and doesn’t happen in any other software.

I’m done using WL for good. I don’t have time to mess around anymore.
Bye.

You seem angry.

I’ve found that not all WL7 settings come across into WL8 when you install, so it might be worth checking the settings under Options | VST Audio Connections and comparing them with WL7.

There might be other setting that would be worth comparing, and the time would be better spent doing that than writing 4 angry forum posts in an hour. How long did it take to make those ~250 angry faces anyway? And did you do the same on the an Ozone forum somewhere?

Funny, that’s exactly the reason I continue to use Wavelab. Good luck finding a better replacement.

@Jperkinski, please, take a deep breath, go for a walk … there are people here who are offering help, including the actual software developer! All PG is asking is whether the problem occurs if you are not using Ozone … don’t assume he’s trying to pin the blame on iZotope, he’s simply asking a question in order to logically analyse the problem.

Sorry for the freak out, but I explained that the issue didn’t happen in WL7, it doesn’t happen in the master section, only the montage master section as you dial in certain settings that I showed. This leads me to think it’s a Wavelab montage master effects issue, which is a new feature in WL8. One that I was really happy to see at first.

I appreciate PG’s help on this forum but I’d appreciate it more if he wouldn’t always assume it’s not a Wavelab issue.
I use Pro Tools and Logic regularly and stuff like this never seems to occur.

The WL8 bugs list is rather large and growing:

Couldn’t create DDP or burn CD when importing WL 7 settings
Ozone 5 graphic issue
Plugin GUI issue when certain plugins inserted after UAD plugs with large GUI
Track UP/DOWN shortcut issue mentioned way back in WL7
Many iLok plugins not loading

This is just what I can think of at the moment.

I’d love to go for a walk but any free time I thought I may have is now eaten up by finding bad files, moving all plugins from the montage master to master section (no shortcut for this) and re-rendering files, re-uploading to client.

For this client, I master the full mix totally ITB. The full mix is on track 1 and then all stems are on additional audio tracks and trimmed to taste. Once the mastering is dialed in on the master section, I can render each version by muting all other audio tracks. It’s not practical to listen to every version of every song. Who would expect that an error like this would occur from nowhere?

I have reinstalled Ozone and the issue still exists. I love what Wavelab could be, but it’s stuff like this that keeps me looking for something better on OSX, something I can trust. I trusted WL7 for awhile and learned to deal with the annoying things, but so far the problems I’ve seen with WL8 outweigh the new features.

Unrelated to WL’s bugs: it never ceases to amaze me that professionals, making a living with a piece of software, constantly insist on using the latest, untested version on time critical projects. I would never, ever, use a new version of WL or Cubase–or MSWord, Quark or Photoshop for that matter, on something that is to be handed in in exchange for money from a client. Install in parallel, test, retest, then phase into the workflow. Anything else is asking for trouble.

r,
j,

We all do it from time to time. :slight_smile:

Straight up, I have to admit I’m not able to help you directly, other than to offer moral support and to say that I am personally confident that if you can hold it together enough to enable PG to reproduce the problem, I have every confidence in him to fix it.

On the other hand (and I do think this is something you should consider especially when there are high-stakes clients involved) it’s not always the best idea to use the most recent release of any product in production. With WaveLab, you can have both WL7 and WL8 installed so there’s no issue there. If a newer product version offers time-saving features then, happy days – but only after real-life testing!

One thing I have to ask though – you say, “it’s not practical to listen to every version of every song”. There are some of us who might think that listening to every second of everything is we let out is effectively the job definition.

Touché, encore!

Seems to be happening most on IRC III mode of Ozone 5. Happens lightly on IRC mode, and a bit more on IRC II mode.

Does not happen on hard or soft mode in Ozone 5. It only happens when using Wavelab fade outs during loud musical sections, not an issue on songs that have a natural decay. Sometimes not even when fading but just near the end of a clip with strong audio.

So, in practice, it happens in the most CPU-intensive mode(s)? A long-shot, but have you tried to increase your buffers? Just as a test?

r,
j,

Yes, I’ve tried raising the playback as well as plug-in buffer to the max and the result is the same. I just did some tests in Pro Tools with the same Ozone settings, doing some quick fades on loud music and there is no stutter or glitch. Same with WL7, no problems. Something is different with WL8 and Ozone not getting along.

Again, this mainly occurs when there is an abrupt fade out using the WL fade out options and play to the end of the clip or file. It happens on both my Mac Pro and MacBook Pro using 10.8.3

It seems like a buffer or cache issue.

Maybe somebody else with Ozone can confirm. Set the Maximizer section of Ozone to IRC III and other settings like I pictured above, put it on the new montage master section (not the original global master section), do a quick fade out of a song at the end of a montage and see if it stutters.

In this case, I’m putting each stem version on it’s own track and muting all other tracks. When I render I choose “whole montage” so each render is technically the end of the montage because in this case it ignores the muted tracks. The glitch is the same on playback as it is the rendered file.

This is a very specific use case, but thanks for coming back to the fold; hopefully PG will soon be able to offer some help. I think we all understand your initial frustration but at least now other users who have a similar workflow they will be able to contribute. You have made a significant contribution in that you have highlighted an issue which can now be investigated and hopefully corrected, which might otherwise have been left for some other even poorer unfortunate to discover at an even less opportune moment.

I can confirm the problem, and this is a WaveLab issue. The origin of the problem is that the plugin you use has a long latency, see:
2013-05-18_08-44-48.png
and the last 371 ms of samples (in your case) are not properly read out from the plugin.

One solution to this problem, is to put a marker at least 371 ms after the last clip (in your example). In this case, audio streaming will happen until that marker, and the problem will disappear.

Of course, this problem will be corrected in WaveLab 8.0.2.

Yes, Ozone 5 is a big plugin with a lot of latency and it can also take a long time to render a long project when you really use all the settings. This was never an issue on the global master section so I didn’t think that the montage master section would be different.

Is it safe to keep using on the global master section without issues until 8.0.2 is out? I was really liking the montage master section and not having to remember to save and reload for each montage.

For normal album mastering, it may not be a problem to add the extra 371ms as a temporary fix, but for some of the library music I master, I don’t use any markers and render each stem version as “whole montage” because the files need to be a certain length and the promo-30 and stinger versions are not to have any extra silence after them, and they tend to have stronger musical content as they fade out.

Last week I handled hundreds and hundred of stems and it’s not practical to listen to every second of every stem due to the high number of files I’m dealing with.

Yes, the standard Master Section is safe to use, as well as clip and track effects. The problem is limited to the Master plugins of the Montage, for plugins with a long latency.