Any suggestions for how to undo this pretty severe formatting bug?

See graphic:


There are no forced system or page breaks I can see when signposts are turned on (which is usually the cause of this sort of thing, I’ve found in the past). I didn’t notice it until I’d done lots of additional work earlier in the chart so would prefer to somehow re-format without having to just do multiple undos. I COULD go through and insert forced system breaks every 4 measures but would prefer not to have to. Any suggestions?
Thanks in advance -

  • D.D.

Actually, let me add the above to my thread about UN-deleting a staff I’ve hidden via the “Remove Staff” function since re-storing the removed staff seems to be what’s causing this bizarre problem: https://www.steinberg.net/forums/viewtopic.php?f=246&t=146682&p=788772#p788772

  • D.D.

Something somewhat similar has happened to me a few times after I have deleted manually inserted system or frame breaks and that usually comes back to the very first frame break icon/flag. Sometimes the property to ‘wait for the next frame break’ gets ticked on and so the program tries to force the entire score on to one page because there is not a second frame break inserted to help it figure the rest out. So, double check the properties of any frame/system breaks you have.

I’ve already filtered and deleted any prospective frame or system breaks but no dice. The only workaround I’ve come up with is to manually insert new system breaks every four bars, but I’d definitely love to be able to fully and properly undo the issue…

Does forcing X number of bars per system in layout options at least handle this automatically? this is so very odd…

Just off the top of my head: is there anything weird about your master frame chain? Is the music frame definitely an MA frame? I’m just thinking that it could be possible you’re working in a Layout chain and somehow haven’t given Dorico permission to spread the music into other frames, via frame filters or something…

I tried that but unfortunately no dice.

  • D.D.

This is what it says at the top of every page when I enable Frames in Engrave Mode (I’m presuming this is normal?) So unfortunately, this may not be related to this bizarre problem:
Screen Shot 2018-11-05 at 10.34.27 PM.png
I’m open to any more suggestions (with thanks!)

Best -

  • D.D.

Actually, I found a workaround: I added some empty bars to the point BEFORE the bizarre behavior began. After the new empty bars, the formatting issues immediately went away as a result. I then deleted the new empty bars, and the problem STILL went away. Very strange though but happy I fixed it.

  • D.D.

There must be a break there, set to ‘Wait for next system break’. That’s the only way that kind of thing ever occurs in Dorico.

Oh, and it’s not a bug, of course: if you have a break set to wait for the next system break, but there is no explicit system break, the end of the flow gets treated as the next system break, so all of the music will end up on one system.