Any way to have Dorico ignore pitch bend info?

I’m having trouble with my MIDI keyboard, it sends random pitch bend signals during playback, or note entry.

Is there any way of having Dorico completely ignore pitch bend information coming in from the keyboard?

Hi @Michel_Edward try this setting in Preferences. It filters all midi controllers though…, but maybe can help (but I am not sure if Pitch Bend is a midi controller) :

If I filter out MIDI controllers, will it affect other aspects of playback?

I pretty much only use Noteperformer, and occasionally use BBCSO with NPPE just for my strings.

Being this option in the Recording section, I think that will only filter what comes into Dorico, and not what goes out (as in playback)

Fwiw, there are known issues with MAudio Keyboards. Filtering CC won’t help. I trashed mine 2 months ago. Problem gone!

1 Like

I have an aging M-Audio Axiom 49 MIDI controller keyboard. Every so often it sends random pitch bend signals. The usual symptom of this is that clicking on a note in a Dorico score will cause the note to play at a different pitch, typically a semitone lower. Playback will have some of the notes playing back at the correct pitch with others not - instant polytonality!

The fix for this particular keyboard is as follows:

  1. move the modulation/pitch bend wheel - the LCD display will show some changing values
  2. press the Ctrl Assign button
  3. type “000” (3 zeroes) on the numeric keypad
  4. press the " - " (minus) key on the numeric keypad - the LCD display should now display “OFF”

Other keyboards might have a similar procedure to disable the modulation and pitch bend wheels.

1 Like

ah, the M-Audio Keystation 88se does not have a screen of any sort.
this keyboard is nearly 20 years old (I suspect that when we got it it was not the latest model, either.)
so, no LCD on which to see values, and no numeric keypad on the keyboard either.

Have a look at this website.
There might be some useful information in one of the manuals there.
https://m-audio.com/support/documents-search

I found this under “Legacy” > “Keystation 88es”.

KSSeries_UGML_01.pdf (805.1 KB)

Yes I am also affected by the pitch bend problem. I read that on some keyboards there are direct methods of disabling the pitch bend wheel. Even without them having LCD screens… I haven’t got round to make my keyboard ignore the wheel yet, though, bit I’ll give it another try.
I’ll try to figure it out again…

I may be wrong, but my impression was that they transmit spurious data, some of which are interpreted as pitch bend, but that it’s not necessarily caused by a faulty pitch bend wheel…

This started very suddenly a few days ago.
At first I assumed it was an issue with Dorico and ASIO4ALL or whatever, or the sample rate.
I kept trying different combinations of drivers and sample rates, but the problem persisted.

But then, while teaching online, I was playing along on my keyboard using Dorico and the piano in NotePerformer , and the pitch would suddenly jump, anywhere from a semi-tone to a rather detuned octave.

I restarted my computer multiple times, tried playing back the orchestral work on which I am presently working, and random instruments would suddenly go out of tune, sometimes a semi-tone, sometimes more.

When I finally turned off my keyboard, Dorico’s playback corrected itself, and I was able to play, multiple times, this orchestral score with no issues.
This was what suggested to me that the issue was the MIDI keyboard sending pitch bend information, rather than a sample rate issue within Dorico.

when I get these terrible out if tune playbacks, I also just switch off the MIDI keyboard and everything is fine…

it does make entering notes more difficult however!

I need my MIDI keyboard for note entry.

You could try to spray it with contact cleaner, or just air to remove dust.

Jesper