Any way to hide rests around cues by default?

Or do I have to hide them all manually?

Also, can I prevent full bar rests for cues also?

Thanks for any help!

Try navigating to Engraving Options > Cues and check if your desired settings can be made.

If they are not in that dialog then I don’t think you can have them as default.