Apple font smoothing in C7

  • apparently it is off. And there is no way to get it back, is there? I’ve tried forcing it in terminal on both 10.6 and 10.8, but that’s a no go. And I have to say new font aliasing does make the whole DAW look cheap and blurry. Especially when you compare it side by side with ver.6.5 “old-school Carl Zeiss-grade-precision fine German design” (as somebody’s already described it in another post).

My guess is this decision to ditch apple font smoothing has something to do with the new resizeable mixer and the overall darkness of the GUI. But the question is:

  • is there any way to turn font smoothing back on for us mac users?
  • or could anybody figure our a possible workaround for this? I’m willing to go as far as disabling certain fonts system-wide and digging deep into hex codes. Yes, this issue is a big turn off for me :nerd:

I’d be thankful for any contributions guys.

Sorry I have nothing to add of value here, I just went through the same thing as you with the AppleFontSmoothing command.

Just wanting to add my +1 on improving the degraded fonts.

Yes, please fix the fonts!!!

I’d missed this post before and hadn’t connected the abysmal text rendering in Cubase 7 with the absence of font smoothing. I’ve logged this twice with technical support (who claim not be able see the difference in the screenshots of C6.5 and C7 I supplied) and am not hopeful of any improvement. It’s a pity though, as I love the new features in Cubase 7, but am having to put up with the ugliest DAW on the market (well, apart from Reaper to be fair) to use them.

Hard to believe steinberg can’t see the difference. It’s very clear to me. 6.5 is MUCH sharper.