Applying Layouts to individual pages or regions of music

Does anyone know if it’s possible in Dorico Pro 2 to apply Layout rules to specific systems of music without affecting the rest of the score? I’m generally enjoying Dorico’s default spacing, but at times I feel like it puts too few bars on a system (looks too spread out) for my liking. I have spent a lot of time tweaking the note space options, but even with the ‘Minimum space for short notes’ option set to zero there’s still too much room.

What I’d like to do specifically is set a range of bars where there are 2 bars per system (Dorico is defaulting to 1), the only thing I can find though is the Layout rule ‘Fixed number of bars per system’ which applies to the entire score! So I guess in essence, is there a way to apply that rule (Fixed number of bars per system) to only some systems in the score? Thanks so much!

You can create a Note Spacing Change event at any point. Select a note and choose Note Spacing Change… from the Engrave menu.

If that doesn’t help you can always force any amount of music in one system by selecting the first and the last note that you want to be in one system and clicking Make into System from the left hand panel in Engrave Mode.

Having said that, I would also appreciate the ability to apply certain Layout or Engraving or indeed Notation Options to a selected range only…

For clarity, I’d like to force Dorico to put two bars per system for this region of music, but not the rest of the score (image attached), any thoughts?

You need to do it manually.

In Engraving mode, add a system break (Shift-S) where you want a system to start.
Two bars later, add another system break.
Two bars later, add yet another system break.
Repeat ad nauseum.
Then go back to the first system break.
Select it. In the bottom panel (still in Engrave mode) there’s a “Wait for next system break” property. Flick that switch.
Repeat this last step for all the remaining system breaks.

… or make a block selection, filter System Breaks and do it once for all but the last of them.

fkretlow, sure! The very reason I didn’t suggest using “make into system” is that the OP would inevitably end up applying to bars 3 and 4, then again to 5 and 6, which would likely mean overlapping selections (the barline at the start of bar 5). That then results in a “why doesn’t this work?” situation, because two overlapping "make into system"s = a big fat mess where the “wait for next” property has been ticked and unticked and then ticked again.

Not that I’ve ever answered this question before, or anything :wink:

To the OP: please don’t write for the Cello in alto clef. Cellists read bass, treble and tenor clefs.

Thanks a ton guys, I’ve got it! Thx for the cello in alto tip too, that was my mistake.

You might save yourself some work (and end up with a prettier score!) if you go into Layout Options and set the instrument names to be abbreviated after the first system - “ALTO RECORDER” takes up a lot more space than “A. REC”.

Leo, I sometimes wonder if you’ve got a catalog of standard answers for standard questions saved somewhere and easily a accessible with some sort of a keyboard macro… Steinberg might as well pay you for the support you give here.

Cards on the table: I have no stock answers at all, though only this morning I was wondering if Daniel does?! ~75% of the time I’m actually on an iPhone, generally travelling around London on public transport. And no, Steinberg certainly don’t pay me, though I seriously considered applying for the Tester job that came up a little while before Dorico v1 was released.

You indicate you’ve solved the problem but I thought I’d mention that the staff size looks awfully large. This is a score and normally the staff size can be smaller than the parts. A smaller size will allow you to get 2 measures on a system no problem. If this is a “performance score”, anotherwords all players read from a score, then ignore my comment.

You have the cello notated in alto clef. Don’t you want tenor clef? Alto clef might be a problem for cellists as it’s never used, as far as I know.

I agree with you notesetter, my first reaction was the same regarding a large “look” to the music. kylefolks - you can try notesetter’s advice by going to Layout Options, Page Setup, and try changing the Space Size. It may improve the look of the score.

As a cellist, I can confirm: never ever use an alto clef in a cello part. It makes the music unreadable from a cellist’s viewpoint.

While we’re off-topic, an anecdote:

I work a lot with a conductor/composer/arranger who shall remain nameless. He largely arranges for choirs, so when orchestrating he puts the violas in treble clef 8ba (as though they were the tenors in an SATB arrangement). He’s rubbish at Alto clef and extremely proficient at working in SATB.

The one time he forgot to switch it to Alto clef, Edition Peters forgot to proof the score - they printed and published it.