Are Midi parts humanised in Nuendo? Mystery Solved

[/b][/b]I have recently been bouncing some Midi parts (drums and keys) to audio tracks in order to reduce CPU demands.

After doing so, all of the part’s appear to be slightly behind the beat even though the original midi parts are quantised to precise bars and beats, so I move them forward so that the first beat is perfectly aligned with the first beat of a bar, both visually and audibly, with no flamming. However, if I look further in to the project, some beats in the audio parts appear to be placed slightly before or after their correct bar positions - as if the parts are being ‘humanised’ in some way.

Is Nuendo doing this?
Are parts ignoring midi quantisation when they are bounced?
Could this be a bug?

I know that BFD2 has a ‘humanise’ feature, but I can not find one in Nuendo.

Any ideas?

No humanizing in Nuendo that I know of…

Are the tracks in question routed to external midi devices or internal VSTs?
The only time I notice this timing inconsistency is with my external midi devices.
(Nordlead2, MS2000, Triton Le)
When I bounce them, they are always very slightly off the grid.
(Annoys me to say the least)

Internal VSTs however, are always exactly where they should be.

It happens with both VSTi’s and external instruments.

The fact that they appear to be slightly delayed does not bother me too much - I just move the entire new audio part to where it should start by putting the first note in the correct place. I would then expect all the following notes to also be in their correct places; some of them are, but many are placed either slightly before or just after their correct positions.

Here is a simple way to test this:

  1. Record a simple Midi part (I’m using a mainly 4-to-the-bar bass part on an Instrument track going to Trillian).

  2. Quantise the Midi to ensure that all notes fall exactly on the beat.

  3. Add a new Audio Track and route the audio triggered by the Midi part to it - Record the audio. This will provide a single audio part on the new track. Mute the original Midi file.

  4. Ensure that the first note in the new audio file lines up exactly with the first beat of a bar in the Project (also with the metronome click). I have to drag the part forward a bit to get it to line up - (Shouldn’t delay compensation be taking care of this?)

This first note should now play back exactly in time with the first beat of the bar. I would also expect all subsequent notes in the same part to play back exactly in time as well, however some notes sound a little early and some a little late. This can also be seen by looking at the audio part.

Can anyone confirm this please?

NB: I have tried the System Timestamp options but they make no difference.

I would do it but I am swamped at the moment.
No time until next week most likely.

I’ll try this test tomorrow. Just from my own personal experience, I’ve always questioned the midi timing.

OK, I did a test and the quantisation came out correctly. What I did:

Used a Click sound. Made sure beginning of transient started at zero crossing and dropped it into Groove Agent SE. Recorded midi on quarter notes for 4 bars. Quantised and bounced offline. Every single hit looked spot on when I zoomed in.

This was just a short, unscientific test, but one thing that could be causing your issue: Maybe there is a different bass sound when you hit the same note (round robin?), that has a (very slight) shorter/longer attack on it?

Thanks for taking the time to look at this Sunshy.

Based on your comments, I tested it again with no Round Robin but it made no difference. For the first few bars the audio looked correct after I shifted the part to line it up with the first beat of a bar, but further along the track the audio notes are clearly not being placed on the beat, as they are in the original Midi file. They are sometime on the beat, or before the beat or after the beat.

I also tried this with a different plugin (Neon) with the same result.

As you say, the Nuendo Midi timing might not be as tight as it should be (even when using in-the-box sounds).


I’m willing to do this test again. At what bar did you start seeing timing errors? Can you send me your project? Maybe use a Nuendo synth or drum machine.

Attached (I hope) is a small project illustrating the issue.

The Instrument track uses Steinberg’s Neon VSTi and the audio created from the part does seem to be in time.

The Midi part in the Trilian folder uses Trilian with no Round Robin (set to to ‘No Variation’) and no effects. You can see that the audio drifts a bit around the beat. It is not a massive amount, but is disconcerting when notes do not fall exactly on the beat.

I really appreciate you taking time out to look at this.

EDIT: The zip file ‘uploaded’ but I can not see it in this post. Not sure what to do here :confused:

You can use or something similar and send me the link via PM. I’ll open it up as I have Trilian as well.

OK, I’ve opened up Chris’ project and can see what he means. Some notes fall exactly on the beat and other are slightly before. I’ll do another test with a percussive sound and see what I get.

OK, I tested this again the same way and timing seems spot on for me for all tracks:

Audio click sound (one event repeated multiple times)
Audio click sound bounced

Midi Click Sound
Midi Click Sound bounced

They all line up. Any ideas on what could be causing it then? Trilian?

Hi Sunshy,

Thanks for doing the test.

I’ve imported your test project and can see that the bounced notes are spot on the beat.

This makes me think that the problem may lie with Trilian. Perhaps there is some randomisation happening even with ‘round robin’ switched off. I will contact Spectrasonics about the issue.

It could also be something to do with bouncing audio from an Instrument track in Nuendo, but I’ll have to test this further.

It could be related to the fact that not all VSTi’s are sample accurate.
Most recent ones are, and I think Trillian should be, but I can imagine older ones like Neon aren’t.

Also, with Trillian there is no accounting for how accurately/tightly the samples are edited.

The best way to check it is with a short impulse sound that starts on the first sample in a sample accurate player like Kontakt…

To answer my OP, Nuendo does not Humanize Midi, but Spectrasonics Trilian does. It uses Round-Robin, Release, Legato and Velocity settings which can affect the actual placement of notes as well as the sound of notes. With these options active, notes bounced to audio will be placed on or near their midi start points in an attempt to humanize the parts.

Turning these options off will result in notes bounced to audio being placed where one would expect them to appear if they were played perfectly in time (except for some slight latency which can be eliminated by pulling the audio part up a bit).

Finding these options is not always easy. For example, turning the Round Robin setting off is not accomplished (as one might think) by going to System/Miscellaneous/Round Robin and setting it to No Variation. For every layer in a Multi you have to go to Edit/Soundsource Folder/Soundsource A / Edit / Round Robin and set it to ‘No RR’, and possibly repeat that for Soundsource B.

To turn Release and Legato off you have to go to Main and make the changes there. This has to be done for every layer in a Multi, but at least there is a Global option there so all Layers can be done at the same time.

Mystery solved.

Eat your heart out Encyclopedia Brown!

I could go on… :smiley: