Arpache 5 and Arpache SX causing unwanted notes to be played when using mute/solo

There is an issue where, during playback, using Mute/Solo on a midi track that have Arpache 5 or Arpache SX as midi insert would cause the arpeggiator to lose sync and play unwanted notes for a brief instant.

How to reproduce :

  • Create an instrument track
  • Record long chord notes
  • In MIDI Insert add Arpache 5 or Arpache SX
  • Play the track and mute/unmute repeatedly
  • Notice the notes to be played erratically for a brief instant upon unmuting the track
  • Now add a Folder Track and put your instrument track in it
  • On the Folder Track, click Solo and notice the arpeggiator go crazy for even longer
  • The arpeggiator loses sync when both activating and deactivating Solo on the Folder Track

This may be caused by the “Chase Notes” preference. It will retrigger the note on an unwanted position. So the produced notes are out of time. Try to disable this pref.

@Louis_R did you try this?

Disabling Chase Notes fixes the problem when putting the Midi Track out of Mute state, but there is definitely an issue when Soloing a Folder Track when it is enabled.

Here is a project file where you can reproduce it.
Note Chase folder solo bug.cpr (424.9 KB)

When it is playing, repeatedly click Solo on the Folder Track.
That will cause the Chase function to activate, even if the midi track was already playing !

Now make sure the folder is not Solo (all mute/solo stated disabled), and instead, repeatedly click Solo on the Midi Track. You’ll see that there is no problem when doing so.

There is a real bug with toggling Solo on Folder Tracks when Chase Notes is enabled !
If there was no issue, I wouldn’t waste my time posting here.

No one is denying. Just looking for a clear way for troubleshooters to reproduce.

The issue has also been found by someone else :

1 Like