Arranger chain and mixdown?

Sometimes I can do an audio export and the arranger chain works fine - but other times, the arranger chain order is simply ignored, and the export proceeds straight from the left marker to the right marker.

Any idea why this is? A bug? Or am I overlooking something?

The workaround is to flatten the project and then export the mixdown, but I’d rather avoid this step if I could!

Is the arranger mode simply not made for exporting mixdowns? The manual says nothing about exporting from the arranger.

Although I have in the past successfully exported arranger chains (previously called “play order”).


I find the arranger chain pretty buggy myself. When I flatten something and press play and then stop, the cursor will return so a certain spot in the project for some reason. If I delete all the arranger chain sections, the behavior stops.

Can anyone respond to this?

Is the arranger chain intended to support an audio mixdown that actually correctly reflects the chain? Was it designed to do this?

Or is it necessary to flatten the chain first?

I’ve had sporadic luck with using the arranger chain in mixdowns, but that luck seems to vary somewhat randomly from project to project.

No one can respond to this? Does nobody use this feature?!

No idea at all, sadly - never used the arranger at all.
What am I missing??

You have to use flatten to convert to linear a linear project format. Arranger is, as far as I have seen, really for trying out different arrangements of a work, it simply allows you to play sections in a different order (non linear) without having to manually move the parts around to try different edits. Once you have decided on a final arrangement, you then flatten. Of course if you are set up to record directly to a second multi-track system, you can simply record the arranger output without flattening first.

I think exporting mixdowns from the arrangertrack works (or has worked), though it is (AFAIK) not supported officially .
You might want to try with higher buffer settings …


Dang. I’ve been using it since it was first introduced as the “play order” feature. It’s especially helpful when I’m composing stuff (as opposed to recording a band), allowing me to try out different arrangements, add sections without having to move everything around, try alternate passages, etc.

Instead of literally copying and pasting repeated sections or cutting through huge swaths of midi and audio and shifting clips left or right to insert a new section, the arranger allows playback to skip all over the place as directed by the arranger track.

Our new single Lethal Protector is heavily dependent on the arranger track…as are a lot of the other songs represented on this widget, and just about all the other instrumental pieces I write.

It’s really an invaluable feature! BUT sometimes when I export with the arranger track on, everything comes out in the correct order. And sometimes it doesn’t. Bummer.

Fredo - Thanks! Not officially supported - there’s my answer. I’d love to see this feature added, though!

DTSR - Yes, that’s the way to do it, just record the output in real time instead of using the export feature. I’ve been using a Voxengo freebie plugin called “Voxengo recorder” in the master buss - any suggestions for something a little less rudimentary?


What if you use real-time export?


Same thing - sometimes it works, sometimes not. I think it’s because the export command is dependent on where the left and right markers are, so there sometimes seems to be a weird combined effect of arranger track order and L/R marker delineation.

Yeah, but your left marker should always be on the left of the right marker.
Sounds silly, but you actually can reverse them, then the timeline above turns red.
If this is the case, export will always fail.


Of course! I keep the arranger track within the locators, and don’t switch the L/R/ positions.

Just downloaded Silverspike’s TapeIt plugin - kind of forgot about it! It has more sync options than Voxengo’s plugin.

Not sure really, if you had a second asio device on your machine you could probably record direct to a second DAW.
I use a mirrored system, running two PCs, networked, each with an RME RayDAT installed, this was the best solution I could come up with to accommodate how I like to work. I like to muck about with processes while recording, that way I usually have something to run with after hours of aimless wan*ery. Means lots of editing though, which is painful.

I had forgotten that SilverSpike offers a plugin called TapeIt, which you plug into the master output - or anywhere you want to.

You can use it to record to a .wav file, and it offers various sync options, including broadcast wav stamping. Works great.

I just set it so it records while the transport is running, and shuts of automatically when playback stops - perfect for an activated arranger track!

Pretty cheap, at $20 USD. Well worth it. There’s also a free version that has fewer features, but I needed the syncing feature.

It would be cool is Steinberg offer something as simple and useful!

so you are talking about mixing down to 2 tracks? I misunderstood, I thought you meant creating different multi-track versions of your arrangements.

Yes - the topic of the thread was about exporting a project with an active “arranger” track - just getting a stereo file of the mix. Turns out the only way to do this without flattening the arrangement is to get a file written from the output as the thing is running in real time.

Okay, this topic hasn’t been touched on for a while, but since I ran into it just today, I want to share my findings:

In Nuendo 4.3.0 through 5.5.5 (only tested on Mac OS X 10.6.8, but both 32 and 64 bits), the effects of the L/R markers and the Arranger List overlap and need both be considered. (Huh?)
Example: I had a linear project arranged, 152 bars, 3 mins 40. Then I came up with another guitar riff that I recorded at the end of the project with an 8 bar gap in between (just for overview reasons), and because i wanted to splice it in just in the middle and move a part from the middle in front of the outro I created Arranger parts to do just that. For both versions I made Arranger lists for quick comparison.
Now the new version is not 3’ 40 but 4’ 00 because it has 12 more bars. And this is where it gets (sorta) funny.

To create a mixdown of the old version which is exactly 3’ 40 I could just set my L/R markers to match the original arrangement (Arranger List enabled, original arrangement selected). When switching to the new version in the Arranger window, the later-on recorded part was properly spliced in, but at the end the mix output file was cut off 12 bars early. Consequently, I moved the Right marker to 12 bars later (or 20 secs later), and presto! the mix came out fine.

As mentioned before, I haven’t tested this in any Nuendo version on a Windows machine, but I think they’ll behave accordingly.
Be careful to set your L/R markers with enough space in between to fit the length of your arrangement (which you can see in the Arranger window).

I try it without checking the “import to audio track” option and the arranger didn’t work. Then i try to do the same but this time i check the option to import the result to an audio track in my project. It DID WORK! Funny Uh??? (all of these reffers to cubase 8)