Artist 11 is not recognizing my Audio Interface


I’ve seen the other similar posts to my problem but they are not helping me, so if anyone can shed some light on to my particular problem I’d really appreciate it please.

I’m using a Soundcraft Signature 12 mixer as my audio interface and it has worked flawlessly until today as Artist 11 has failed to recognise it at all.

Yesterday I was mixing down a project before turning off for the night and I noticed a Windows update was being installed before I closed down. Nothing unusual in that and everything shut down as expected. However, today I just cannot get Cubase to recognise my interace ASIOs… The only option I have is the Generic Low Latency ASIO, which is no us to me as it doesn’t allow me to interface with my mixer.

I have uninstalled and reinstalled the Soundcraft drivers twice and rebooted but no joy. I have also uninstalled and reinstalled Artist 11 twice and still no joy. I have checked all my cables, deleted the USB connections and rebooted to reinstal them and still nothing.

Does anyone please have any ideas as to what might be the problem as I have lost hours today trying to figure it out?

Many thanks.


Try to reinstall the ASIO driver, please. Make sure, you install it as administrator, please.

Thanks Martin for the quick reply, much appreciated.

It didn’t work unfortunately but I found a solution on the Soundcraft website about Windows 10 enforcing signature drivers by default.

I followed the instructions and then I followed your advice again and reinstalled the driver as an Administrator. Incredibly it worked and I am now up and running. I wish I had found this out about 8 hours ago as I have lost the day’s work.

Thank again for your help.

1 Like

Hi again,

The ASIO drivers have disappeared again in Artist 11., I tried exactly what I did before (twice) but still the Soundcraft Signature 12 USB mixer isn’t recognised.

What is crazy though is that when I load up my old version of Elements 10.5 LE the Soundcraft drivers work perfectly, so is this a Windows 10 problem or a Cubase Artist 11 problem?

I’ve just opened both Elements 10.5 LE and Artist 11 at the same time and Elements has the drivers visible but Artist doesn’t. This is doing my head in!

Does anyone have any other ideas for me to try please, other than of course work with 10.5 LE?

I’m loosing so much time just reloading and restarting over and over again.


I think I’ve cracked it.

Although the mixer did show up as a sound device in Device Manager and the driver was ok (I reinstalled it anyway), it was still not visible in Artist 11, even though it was visible in Elements 10.5 LE.

I looked around on the forum and although not in the same topic I eventually found there was some concern about the Cubase Low Latency ASIO causing conflicts with other manufacturers drivers. I deleted it and immediately Artist saw the Soundcraft driver and I was up and running again.

I was blaming Windows 10 for the problem but it seems it was a Cubase problem.


I’m glad you sorted it out.

If you mean the Generic Low Latency ASIO Driver, this has nothing to do with Cubase. This driver is provided by Microsoft Windows.

Regarding the statement you sent above, I would say it’s on Microsoft and his driver side.

Hi Martin,

Yes I was talking about the Generic Low Latency ASIO Driver, so thanks for pointing that out.

I must apologise for my mistake and blaming Cubase. I thought I’d read it was a Cubase installation and as I found it in my Programmes under Steinberg, along with the other Cubase files I assumed it was a Cubase and not a Microsoft driver.

If there is a known conflict with other manufacturer’s drivers maybe that should be made a bit clearer in the support section.

Anyway so far I’m still working ok - fingers crossed it will continue!