Artist 9 installation problem

I just went through the installation process for a new edu version of Artist 9. I made first attempt that seemd to hang so exited and started again. An error code 1618 appeared but installe=ation and copying of files then continued until all were ticked. This ended and then nothing else happened. I attempted to open the e-licencer centre and got an lcc.exe system error message:

api-ms-wm-crt-runtime-l1-1-0.dll is missing - reinstall the program (or some such)

please can you advise on the problem and remedy ?


See this article, please. Or this here on the forum.

Running into problems with this :unamused: I tried uninstalling the C++ 2015 prog in windows and installing new instance, but the damn thing has hung forever… I tried unistalling the new instance and re-installing but it now tells me I have to complete the original installation. I have no idea how to accomplish this. Any advice greatly welcome!

Ona separate issue re: the original attempt to install Artist 9, I do not see anything in the programmes list that looks like CUBASE has installed … I see many listings for associated programmes, and one for VST transport, but nothing that looks like the main programme, what should I see for the full installation? I am suspicious that something went wrong with my initial attempt since I had that first error message , and that only the associated programmes have been installed.

I always seem to have problems with music software, I just want things to install and WORK :neutral_face:


I’m not sure, if you can complete Cubase installation without proper C++ 2015 installation.

Regarding the Cubase item in the list, I’m not sure if the Steinberg prefix is for this application. Double check, if it’s in the list as Cubase, nit Steinberg Cubase, please.

All of the items shown in the image are what appears in the Windows 7 Control Panel/Uninstall list. I did not have any other Steinberg products on this computer as it was a clean re-installation of Windows.

If I look in the All Programs list in the Start window, the only thing that shows up in the Steinberg folder there is ASIO Generic Low Latency Driver setup. If I look in Program Files in Windows Explorer there is a Steinberg folder which has two sub-folders, one for ASIOglldsetup, one for VST plug ins (containing further folders for Padshop and Retrologue) . I do not see anything that looks like an icon or folder suggesting Cubase is installed or there to be opened . I am assuming I OUGHT to be able to do this, even prior to registration (?)

My question regarding my original attempt to install Cubase, independent of the apparent problem with the C++ 2015 issue, is whether there was a problem with installing the basic program. If I exited whilst installation was in progress, would this have then created a problem on my subsequent attempts to install ? As in, is there an unfinished installation being picked up that would prevent a new attempt? If so, how would I either complete the unfinished installation, or delete it in order to try and start cubase installation again?

Regarding the C++ issue, I am similarly getting a message saying that there is an installation of it that needs to be completed. The program appears in the uninstall list after me deleting and attempting to re-install a new instance, but I am still getting the “api-ms-wm-crt-runtime-l1-1-0.dll is missing” error message if I try to click on the elicenser centre icon.

In any case, I would recommend to use one thread for the single issue only.

Regarding the api-ms-wm… Search the forum here, please. It was solved few times already here on the forum.

Regarding your installation issue, what appears, when you try to install Cubase again? Where does it stop? What is the last screen?

Yes, you can install Cubase without registration and without eLCC.

I have just attempted to install Cubase again. I searched for updates and downloaded 9.0.10 then ran installation. The installer identified that Cubase was the only item to install as others on the list were already installed. I ran the installer and it appears to hang immediately in the elicenser control setup - it says “installing VC redistributable” and has hung on the appearance of the first green progress bar. This has not advanced for 15 minutes.

OK, so it seems it always stops on the eLCC. Solve the VC redistributible (solved here in the forum already), please.

Here or here.

Yes Martin - solving this via this method is what I have been attempting several times up until now. I have read and followed the instuctions in the two articles and via the Microsoft download page. That is:

  • have uninstalled both instances of VS redistributable C++ 2015 ( both x64 and x86)

  • have downloaded and attempted installation of new instances of the above

Although both programs appear in the control panel/uninstall list I am doubtful whether installation actually completed for either program - there was nothing in the installation dialogue that told me installation had completed or was successful, it appeared to hang at a certain point yet again.

I have tried this several times and I am still getting the “api-ms-wm-crt-runtime-l1-1-0.dll is missing” error message when I click on the eLCC icon, and I still cannot install Cubase…

Ok I have cracked it!

The VS redistributable C++ 2015 progs were not finishing installation. I searched and found guidance on this via some Windows 7 forums where people were experiencing the same problems. The workaround involves:

  1. switch off Windows Update
  2. Uninstall instances of VS redistributable C++ 2015 progs
  3. Install new VS redistributable C++ 2015 prog from locations linked in posts above
  4. in Task Manager close wusa.exe
  5. When installation hangs do not exit the installation but switch off the PC
  6. Re-start PC and installation completes

I did this for both (x64 and (x86) versions of VS redistributable C++ 2015 progs and after this, and a new shut down and re-start of the PC I was able to install Cubase and run eLicense to register the product.

Thanks for your help Martin, I would not have got this far without your input!

And thanks to you for letting the Forum know how you solved it so it’s here for anyone else who runs into the same problem. Nice one and glad you’re up and running!