Artist Transport: Key Commands don't work SOLVED

I just installed Avid’s “Artist Transport” (in addition to Artist MIX).

  • Newest Avid Software and Driver 3.1.2,
  • Updated the Firmware of “Transport” to 1.6.2.
    Further I work with with Cubase 7.5.1 / WIN7, 64 Bit.

The Jog works and I’m also able to assign the EuCon orders to all the knobs,… to the keypad as well. No problem so far. But…
The keypad itself doesn’t work. So I’m not able to enter a value by the Keypad of “Transport”.

Do I need to program also the 1,2,3,4,5 and so on? If yes, what are the orders. (I tried it and I believe that I did it the right way - but still no possibility to enter values by the keypad…
Does anybody got the same case or am I doing something wrong?


Same thing here…

Hello again
Here an information in addition to my first post:
Assigning a command works for…

  • Wheel Commands (Jog)
  • Wheel Commands (Shuttle)
  • EUCON Commands

But not for…

  • Key-Commands
    So the Keypad doesn’t work itself but also Key Commands assigned to the other Soft Keys don’t have any consequences, don’t lead to a result.

I suspect that this is a problem of Cubase and not one of “AVID Transport”… ?


What are your trying to do? Let me know and I’ll see if I can get it working here.

I don’t understand what this means, can you explain it differently?

For your question about the Keypad on Transport. The manual says you can use the keypad for numeric entry, however I have re-programmed mine for marker locations, so I don’t know how they are programmed by default. If you open Eucon and look at what command is assigned to a number on the keypad, is there anything there?
Anyway, re-programming the Keypad to numbers is easy and works fine, I tested it here.

Not here… I assigned numeric values 1-9 to the corresponding Transport numeric key pads and they do not work. Eucon commands work as expected.

Did you program numbers from across the top of your keyboard numbers, or the numbers from the keypad part of your keyboard, (I hope that makes sense) because I think Eucon sees them differently.

I added some information within my second text: I’m not able to assign KEY-Commands - and this not only within the keypad-possibilities.
To be more precise: The assigning process within EUControl works as it should but I don’t get any effect within Cubase…

in other words:
We get 6 Softkeys, a numeric keypad and some transport keys with Artist Transport. Once assigned the EUCON-command “Play” for example it plays Cubase with all different keys we have.
But my problem is now assigning a KEY COMMAND!
Example: “Ctrl + z” (=UNDO). Even if the programming itself works well within EUControl UNDO doesn’t happen after pressing on the just programmed button within Cubase.

Both… No joy…

Whether using the top rank of the keyboard (the ‘natural’ numbers) or ‘special’ key commands \p1…\pn to activate the numeric keypad values the results are the same.

I even created a macro mapping the keystroke ‘1’ to a macro named ‘Key1’ and that did not work either…

Thanks for your effort, Johngar
I tried both possibilities. If you say that it works well with your system: You are on a MAC - as it seems. Could be that this matter belongs to the WIN-side. So it also could be a matter of EUCon.
So I will start a topic at AVID about this case.

I understand now.
One thing to check in Eucon when you are programming the softkeys or keypad buttons, make sure the “shift” box is not ticked. If you don’t already know this, you can have 2 “pages” of commands for the buttons, one page without shift pressed and one page with the shift button pressed.

I am using Windows 7

Hello again
It seems that I could solve the problem by myself… thank you Internet.

The problem is probably the driver which was installed by the Original-DVD/CD. The newest got another status as it seems. It changed from unsigned to signed or something else. Obviously it changed not in his number so once it is installed the newer EuCon-software doesn’t exchange the old driver.

So if you get a new AVID ARTIST - piece you should directly install the newest software/driver from Avid’s website.
Do not use the Drivers/Software from the original Installing CD!
Unfortunately this isn’t pointed out on the Quick-Installing Paper.

For all others who have problems with the keypad (on a WIN-system) should go to the “Geräte-Manager” in Windows.
(Sorry, don’t know the English expression)
You can probably make out yellow exclamation marks with the Avid-Midi-Driver and the Avid Keypad-Driver.
If this is the case try to delete the drivers directly in the Gerätemanager.

Uninstall Eucon/Avid-Software

  1. You will get warnings and other messages. No problem. (We need to do this here because the uninstall routine will not remove the drivers)
  2. Uninstall the Eucontrol-Software
  3. Restart the Computer
  4. If you have a registry cleaner you could use it before you install the software again
  5. Install the newest EuControl-Software (3.1.2 at the moment)
  6. If all things are going well you should say yes “install driver” (twice) during the installing process.
    If this not happens the old (wrong) drivers are still installed… :imp:
  7. After task 6) you should have Avid-Drivers without yellow exclamation marks within the Gerätemanager.

Go on and your Artist Transport is able now to use the keypad and all the Key-Commands.
Good luck!

Beat - Great sleuthing!! Thanks for this… I am up and running!

I am happy you were able to get it fixed.

Thanks for your help johngar