ArtNet output 1.4.7.0 & 2.0.12

Simply does not work. Network monitor shows no ArtNet packets at all.
MacBook Air. Intel, Somoma

Hi @CliveJ,

hm. Have you checked your “Device / Connection” configuration? I did a quick check on a macOS system.

  1. Start VL, New Project, Select TRACKS
  2. Add DMX Track
  3. Select “DMX ArtNet Out” device for Output
  4. Create Clip, add some events to it
  5. Start Transport

On another macOS System I’ve started the app “ArtNetView”. And there I see the incoming DMX events.

My TRACKS setup

My Connections setup

Have you tried a new project? What could be the difference?

Can you give me some hints of that one? Which software? It’s running on the machine with VST Live?

See you,
Michael.

@spork - Hey Michael!

So……
I’m running dot2 sw on a Windows PC and using an artnet to DMX interface to output to the lights.
On the MacBook I have Wireshark and VL
The network consists of the MacBook, Windows PC and the DMX interface which is wired to the Windows PC with a network switch. The MacBook is wirelessly connected via an access point connected to the wired network but it doesn’t matter if I directly connect on a wire - the following still applies.
The MacBook is sending MTC to the Windows PC via wireless MIDI which works fine.
So I run the song and the DMX interface controls the lights as expected. I can see Artnet activity in Wireshark and record it in VL. It’s all on universe 0.
On playback I can send the DMX to the DMX mixer and see the sliders moving.
If I set VL to output to ArtNet then Wireshark shows no ArtNet packets at all and the DMX box shows no activity.
I haven’t tried it with a new project but I did a new project test a month ago with a new project and the results were the same.
It did work with a much earlier version of 1.4.x but I can’t remember which off hand. When it stopped working in the VL Mac version the Windows version was still working so I’m guessing it’s a Mac issue.

@Spork Hey Michael!

Can you confirm which version of MacOS you are testing on? I’m on Sonoma 14.5 and since I upgraded to it I seem to have lost all DMX in/out even in the previous versions that were working.

… we’ll check. Thank you for reporting,
Michael.