Asio Drivers - How do you manage them?

I’m being frustrated with loading up Cubase ready to make some music and no sound comes out. I actually have no idea what’s going on with it - I’ve restarted it several times, closed all other applications, restarted again, changed drivers, restarted drivers, and nothing. I’m pretty sure the problem will go away once I restart the PC but it’s really frustrating having to manage this.

One other issue I have is with the “stop drivers when Cubase is not in use”; this seems like a really useful feature but quickly gets annoying. The issue is that once you go on Youtube or something that uses audio you need to restart the drivers once you get on to Cubase - but you can’t do that, because you can’t click on the toolbar because it shuts down the drivers. You have to go and un tick the box and then go down and do it. There should be a feature where it only shuts down the drivers when Cubase is minimised and automatically restarts them when you load it back up again. Or something like in ableton, a button at the top where you can quickly turn them off and on.

Hmm. never had that problem. You know how to select your driver in Cubase right? And the ‘Release Driver’ checkbox under the ASIO drop-down menu? It should allow you to play whatever you want, without switching anything ever.

Please disable windows sounds from using your ASIO enabled audio device and re-start Cubase.

I am on expert tehcnically but…

Firstly you dont say what driver(s) your using. If its an old Asio driver, then you need to update.

In the old days some cards did not like to serve more than one master, but my (saffire mix control 3.1) Asio lets me do this. I often run band in the box and Cubase at the same time (BIAB using Asio too)

What sound card are you using - indeed are you using a sound card?
On my system Utube uses the built in driver for Windows (and so you get windows volume controls) and my pro audio uses ASIO (where the volume is mixed in the custom driver interface)

As for unload Asio in background, I leave this alone its hassle. Keep it out of the euqation at least for testing purposes first.

Definitely give your system/interface specs.

Typically, you would want all audio to use the same ASIO driver/interface, by selecting your interface as Windows default audio device as well. Unless, you are working without monitors connected to the interface, then you are not really using things as they were intended.

I have a Roland UA-1G and it allows Kernel Mixer and ASIO audio streams to operate simultaneously but I never work with the monitors up and am careful with programs that weren’t designed with Windows 7 (or Vista) in mind.

I have managed to solve the problem so far

I’m using whatever sound card (if there is one, I don’t know much about them at all) is on my motherboard and Asio4AllV2 drivers, I have Cubase 7 Artist, Windows 7 Ultimate, an i5 CPU at 3.1ghz and 8gb of RAM, however I am using 32bit Cubase.

Can someone tell me where I can find the options to “disable windows sounds from my asio device” or to “select my interface as windows default audio device” ? These things seem to contradict so I’m not sure what’s going on here

Start-Control Panel-Sound.

Asio 4 all is OK ish. I have only used it a decade or so ago. As I say there are many that are more techy than me, that can help you with specifics.

However - check out the Cubase operation manual or" Getting started" for a basic set up guide.

When you post, be more specific don’t make comments like ‘I have managed to solve the problem so far’ specify the issue solved.

Put your hardware and software set up into your signature so it shows in every post. Helpers need to know what CPU, how much RAM, Cubase version, sound card, sound card driver

Basically. Cubase works better with a good sound card. If your on a laptop you can get usb sound cards. Latency is an issue for MIDI especially, this is the lag between when a key is pressed and when the sound is produced. A decent music production sound card will have low latency which is something under 6 msec.

If you want to play in via a keyboard you need to set up the MIDI in Cubase too.

32 bit Cubase has an upper limit for RAM - aournd 4 gig that it can use - lots of which is actually taken by WIndows. 64 bit windowes will only run on a 64 bit system with Win 64 operating system

Don’t worry if it all feels overwhelmijng at first it does take a while to bed all this in.

32 bit Cubase has an upper limit for RAM that it can use - lots of which is actually taken by WIndows.

I do understand these things - I am not being specific enough, I’m sorry. I’m on 64 bit Windows using 32 Bit Cubase because VSTBridge crashed cubase a LOT and I don’t want to buy that other VSTBridge alternative, I’ve never had a problem with RAM usage as of yet, and I’m putting off buying a sound card as long as possible.

I figured out the problem was that for some reason it unmapped the outputs on Asio4All. However it takes restarting the system in order for the outputs (“HD Audio Line output 1/2”) to be able to set again. I’ll take your suggestions and try and fix them.

Save your presets in preferences and VST connections. J bridge is cheap and there is a trial