ASIO drivers only available in Windows 7 Safe Mode

Hi, there!

I have a Windows 7 Home Premium 64bit Dell XPS17 (L702X) laptop which I have used for the last 2 years for music recording. However, for the last few days, no audio recording software has been able to detect the ASIO drivers for the audio interface I use (MOTU UltraLite mk3 Hybrid), or any other ASIO driver for that matter.

The laptop produces normal windows sounds and the windows media player plays any mp3 I ask it to play, but the programs that require the use of ASIO drivers (Cubase 5, Console 1.6, etc) cannot detect them. In their ASIO driver selection menu, all it shows is “ASIO Multimedia Driver” (I’m guessing it is windows basic/default driver), but none of the several ASIO drivers I have installed show anymore (MOTU ASIO Driver, ASIO4ALL, etc).I have tried re-installing the device specific ASIO drivers, but to no avail. I have also tried uninstalling all relevant pieces of software that have been installed since I last used it successfully.

Also, I don’t think that the problem is in the device specific drivers because when I start windows in Safe Mode, then the programs detect all the ASIO drivers. For this reason, I believe it must be some sort of Windows 7 service/driver that has got it self switched off/corrupted and is impeding the loading/starting of the ASIO drivers when it windows starts in normal mode.

Can anyone please help and shed some light on this?
Maybe on a way to check the health status of the relevant windows services/drivers?

Many thanks in advance!

When weird stuff like this happens I’ve had to resort to a System Restore, which has saved me many times over the last several years. It’s completely reverseable if it doesn’t do the trick.

I also have made it a point to use an imaging software (I use Acronis) in case of a complete failure of some kind. You’ll want to consider that for the future when you get things back in working order :bulb: THAT has saved me MANY times!

I’ve never experienced your exact situation, seeing ASIO drivers only in ‘Safe Mode’ but I’d have to imagine something in your preferences/settings got screwed up, so I’d look at all that.

Thanks for your reply, SYNC.

I’m afraid that the System Restore is only showing me restore points for yesterday. Not far back enough…

I’ve uninstalled everything has been installed since then (except for Adobe flash player and windows updates) to no avail…

Any other ideas?

As general practice, I always disable Windows sounds in my music machines, and don’t use my DAW for anything but making music. I also disable my mobo’s on-board audio.

Another thing for you to check… Many times I’ve had to restart my audio drivers in Windows ‘Services’. The times it’s been a problem, I couldn’t open my sound cards interface, and maybe even couldn’t open the drivers within Cubase…I forgot about that.