Asio Guard causing VST instrument to freeze

Asus mainboard
I7 3rd gen
24 gig int. Mem.

Win 10

Sound card: Apollo Quad UAD2 Firewire800 (latency 128 samples)

  1. Make new project in Cubase 9.010
  2. Turn on Asio guard with settings to low
  3. Insert VST instrument (f.a. Groove Agent4 or Halion Sonic 2 or 3 in my case)
  4. Activate the monitor or record button
  5. De-activate it again
  6. Then activate it again
  7. Now the instrument freezes
  8. If you try to remove the instrument from the slot Cubase9 will also freeze

With the Asio Guard set to normal or high it better but still I get freezes…
If I turn off Asio guard, the problem is gone…

It works fine in Cubase 8.5… Even with 32 or 64 samples latency

I too have the same problem but with vePro. Asio Guard is set to high in my case. When I close a folder that had an record enabled track in it, about half the time Cubase will freeze. It also sometimes happens when I change tracks.
If asio guard is off then I don’t have the issue. However due to the high number of instruments I am running I need asio guard on.
If anyone is interested at steinberg I have the crash dumps.

Cubase 9.02
Windows 10
VePro 6
Steinberg UR824

Sorry I should reformat this:

SuperMicro x10dax motherboard
Dual Xeon 2687wv4
Cubase 9.0.20
Windows 10
Steinberg UR824
Vienna Ensemble Pro running on same machine

  1. Record enable an instrument track or a midi track sending to vePro
  2. Close the folder that contains record enabled track
  3. The folder now becomes the selected/active track
  4. Cubase will freeze and never return. Have to end process in Task Manager

I have a process dump (two of them as it happened three times today) if you want.

In case anyone is currently researching a similar issue, I believe VSL advises that Asio Guard should be made Inactive in Plugin Manager (click “i” to open Information pane) for all VEP plugins.