ASIO options

I am running the trial download of Cubase 6 and my Edirol UA25 has disappeared from my ASIO options in Device Setup. ASIO Direct sound, POD X3 and Low latency are there still. When loading Cubase 6 I get the following message-

ASIO Direct Sound Full Duplex Driver message " The currently installed soundcard driver does not support Direct Sound Input. Recording audio is not possible."

Devices & Printers reveal the Edirol there in playback but not in recording.Troubleshooting does not provide a fix.
It is the same in my Studio 4 set up.
Can anyone suggest a fix or whether its a Dell, Realtek , Edirol or Cubase issue.

Dell Intel Core 2
Windows 7 (32)

I take it you’ve tried a restart of the computer? making sure the interface is plugged in before you switch it on?

Yes I have but I just did it again to make sure, still not there. I have plugged it in at various stages of firing up but it does not pop up as a device. I have reloaded drivers for the Edirol but again no joy.


That message from my experience just means something is haywire with your driver or soundcard. Not much use.

When I had this issue with my Lynx i removed all drivers. Rebooted. Reinstalled. Rebooted. Then things were back.

Make sure you check for your latest drivers also. And make sure you have the right bit depth on the driver to match your OS and Cubase.

Thanks for suggestions they have obviously pushed me in the right direction for I have solved it. I had inadvertently knocked the “advance” button to off on the back of my Edirol which had sent my drivers awol.
Switch switched and drivers re-established.