ASIO Overload


I’m having a problem with Cubase 6. The ASIO meter keeps overloading. I am using about 6 or 7 vst instruments plus many inserts on each track, and i could understand why it was overloaded with my 4 gb memory. But i just installed 8 gb memory and the meter didnt go down at all or run any smoother? What else could make it play back smoothly?



Ram wont really have any affect on ASIO performance.

I am using about 6 of 7 vst instruments plus many inserts on each track

Sounds like you have reached the limit of your systems capability.

The usual way to gain more ASIO headroom is to raise the soundcards buffer size.

Mac, PC?? CPU speed?

It’s a PC, HP pavillion dm4. i5 processor - M450 @ 2.40GHz

how could or would I check the soundcard. The buffer size is already at the (2054?) maximum.

What is the soundcard?
That max buffer setting could be your trouble. It’s way too high and some soundcards (Emu?) have been known to have glitches at very high settings. Try 256. If no trouble try 128 etc. halving at each step and as low as you can. If you hear crackling then back off the buffer to the last one or even second setting that worked (going back up the buffers). 128 will probably do.

Buffer settings are, for live recording input, supposed to be as low as you can get so you can monitor yourself live and yet not slow the dataflow which makes crackling noises. The crackling being the computer, like the postman, trying to get a full sackload (the bufferful) of mail thru the letterbox instead of one by one. The door creaks now and again.

The soundcard should have a “Control Panel” program installed where you can change the buffer settings.
If using an onboard soundcard then look up “ASIO4ALL” on the net. It’s free and you will be able to reset your buffers to a lower setting.

You don’t say what soundcard you are using. Is it a pro audio interface with decent ASIO drivers??
(EDIT…sorry I see Conman already asked this)

The other thing to look at is core loading…the cores resources are not always shared as best they could be.
All plugs on a single channel will use the same core.

Open your task manager/performance tab to see the loading on each core. If one is significantly higher than the others, chances are this is your problem.

Multitimbral sample based vsti such as HalionSonic or Kontakt seem to be the worse culprits for this & not loading multiple banks into one instance but using separate instances can help spread the load.

If it’s lots of fx plugs on a single channel causing the problem then routing the channel via a group & moving some plugs there might also help…in the long run it’s probably a good idea to keep an eye on cpu useage as you add plugs & try to use the heaviest users more sparingly!

Oh & also worth a try is switching Hyperthreading to whatever state you aren’t currently using! If no different either way I’d probably leave it on.

Alright thanks for the replys,

I am using the onboard soundcard that came with the computer, and I use the direct x ASIO driver that came with cubase, although I also have the ASIO4ALL and it doesnt work any better. Would an audio interface make a difference with the ASIO time usage? I don’t know a lot about soundcards, and I hardly do any live recording other than one track of vocals.

The second meter next to the ASIO is always at its lowest. Nothing ever even shows up on that meter - I believe that’s the CPU Processing??

And what is the hyperthreading process you were talking about?

A “proper” sound card would be an improvement, your playback will sound better and you will be able to achieve a better feel in Cubase due to reduced “lag” from running lower buffer size.

I bet you’re using the FX efficiently, thus loading the system up prematurely.

Instead of chucking reverbs and delays (and the like) into insert slots, have you tried using them on FX channels and utilising the FX sends from the channels. That way you can share FX across many channels, usually achieving the same result but not having to load and run loads of reverbs, a sure fire way of running out of processing power fast.

The other meter is the disk performance meter, nothing to do with the CPU. If you want to see your CPU usage, go into Task Manager.

A card with decent ASIO driver ought to make a difference but difficult to know how much.

First thing you should do is to check your actual CPU use across the multiple cores as I explained before.

If you can also follow splits advice to use less inserts it will help…really there shouldn’t be much need to have loads of plugs on vsti…what are you trying to achieve by stacking all these plugs.

Hyperthreading can be switched on/off in the bios. (Only leave it off if it improves things… otherwise turn it back on)

Alright i took a look at the task manager, and the 4 graphs (i think they are the different cores) were raised up pretty evenly, but when i let the song run the CPU level was anywhere between 30 and 60, and the song was playing delayed and choppy. The cubase application wasnt using more than 50 percent.
Then occasionally the CPU would move up into the 70 -80 range and it would play smoothly… i’m assuming thats what i want, is there any way to make sure the computer is using than much processing?

Also, yes I am filling it with plug-ins, and I certainty can get by with an fx channel, do you always do that? I thought it would be better to have compressors and x tweaked slightly differently for each sound though - but i guess your telling me it’s common to lump them all together?

And i’m also processing the percussion samples live, I know i could export all those and re-load them. But i’m still curious why it overloads. I thought the computer would be able to handle more, in case im doing more demanding projects in the future or simply for the convenience.

(and by the way i tried the buffer size at the minimum of 512 and it was much slower and more cut up)

So it plays better when the cpu use (across all cores?) is higher. That’s odd.

Have you activated the Steinberg Power Scheme?..that disables core parking which might cause something like that…BUT it’s highly likely your performance is being limited by the onboard soundcard & crap DX driver.

Also, yes I am filling it with plug-ins, and I certainty can get by with an fx channel, do you always do that? I thought it would be better to have compressors and x tweaked slightly differently for each sound though - but i guess your telling me it’s common to lump them all together?

Not exactly. Compression is usually inserted as required per channel or sometimes on subgroups (or both!), reverbs & delays would usually be on an fx send.

As pointed out there are certain FX that suit inserts (compression being one) and others that suit sends (reverb being a good example).

The way to tell is, if you need to set a mix between wet and dry sound, then that is a good candidate for a send.
If the mix is 100% wet then thats a good for an insert.

If you are trying to run 10 Reverence reverbs then that will load up the CPU when you could probably get away with 2 or three!

Proper management of plugins regardless of the computer, is all part and parcel of “Audio Engineering” in a DAW.


I turned on the power scheme - it didnt make a difference. I also note that the ASIO duplex driver has input latency of 300ms output 30ms while the generic ASIO driver has input 20ms and output 20ms, im not sure why.

Yeah it was running much smoother when the cpu was running high. The other thing is i tried turning off all the inserts and vsti that i was running. I turned them all off, when i started turning them back on, i could only turn on 4 inserts before the ASIO meter already maxed out … it should be able to load up a lot more than that right??

I think your expecting simply too muchfrom a 2.4 dual processor and built in soundcard on a laptop


You bought a $600 program and you’re trying to run it on a $100 computer. You need at least an i5 computer (for longevity folks) and a professional soundcard.
The duplex and generic ASIO drivers are as primitive as you can get. ie: You’re now running a $600 program and powering it with a 40watt 50cent lightbulb. They’re just for testing the installation of Cubase to see if it works. “Yes, Cubase sounds awful but it works. Now buy a soundcard.”
Basically I’m saying the same as Hippo but with the addition that you bought Cubase without knowing what you were doing.
There is a large club for that. I’ll have to warn you that if you persist you will have a two year learning curve and an empty wallet at some time soon. Been there.

No i had no idea :wink:

Alright i’ll get some new gear, over time.


Just to note - I didn’t change anything and now it works running at about 30% proccessing power totally smoothly… I’m not sure why it wasn’t woking before, but i guess its not a problem with the computer I have.

Chances are something has changed though!
Are you running it on battery instead of plugged in…or vice-versa…or did you unplug some usb device or switch off your networking or something?

Usually these things don’t fix themselves. Might be useful for you to know what caused the problem for next time :wink:

  1. Turn off wireless if it’s a laptop