ASIO performance spike on first playback

I have several projects that, when playing back, the ASIO usage never comes above 25%. But, the first time I playback, after loading the song, the ASIO performance spikes and the playback glitches. If I rewind and play the same section again, there is no problem.
Is there some preload setting that is set too low? Or is there another solution to this problem?
Thanks in advance.


Increase the Buffer Size, please. And I would also recommend to check the RAM memory speed.

Thanks for the suggestions. Increasing the buffersize doesn’t solve de problem. And my RAM (12 Gb) has been the same since version 7. The problem started with version 8.5.
The only new thing is a PowerLine network adapter. I will see if that’s a factor, but I doubt it.


Test your system by Latency Mon, please.

LatencyMon was all in the green and not the problem. The culprit was Core Parking. Some processors went to sleep and woke up to slow… Hence the glitch on first playback. On second playback all cores were awake :slight_smile:

I have the same issue on first play back. What exactly did you change to remedy this? You mention Core Parking…is there a setting to modify? I see you’re on a PC…I’m on Mac…hmmm

Could be a sampler plugin that caches all used samples into memory/ram during the first run and when the samples are loading from disk causes the spikes. After the first run all used samples are cached in ram and does not cause spikes when played back. Not a solution but a possibility for your problem. If using sampler, test to configure it to load the whole instrument into memory before first playback and test if the behavior is still the same.