ASIO Sample Rate has changed problem

I was mixing down from 32 bit float @ 48kHz to 44.1/24 bit. I then went to listen to it in Windows Groove player. This required me to change the sample rate to 44.1 in the UAD Console. Then Cubase prompted me with a dialog question, which I wasn’t sure how to answer, as neither applied to what I was doing.

It asked me if I wanted to allow different sample rates in the project.

What effect does this have on Cubase in terms of how it handles sample rates?

What does it actually do to allow me to use different sample rates? Does it take away or take up any resources doing this?

The project is 32 bit float @ 48khz, so I suppose I did not want to do either option that was presented to me. What should I do, and is there a way to stop the box popping up all the time?

This works very differently to the Focusrite audio interfaces I’ve used in the past, as they seem to happily let me choose different sample rates etc in Windows vs in Cubase without any complaints or issues. Is there a way to set the Apollo Twin Mk2 thunderbolt up the same?


I’d say it’s asking if you want to run with sample rate set differently to interface. That’s all. You could say yes, then change the sample rate back to 48k.
Cubase will always allow any sample rate audio you want to import but it will play at wrong speed if it’s not a match for the project.
I don’t think this is any new change to that. Just a warning you have a mismatch.

You sure you can’t just change the Windows audio setting rather than using UAD Console which is setting the SR for ASIO?

AFAIK windows defaults to 48k, I always change it to 44.1k when I set up a new OS.
You have Cubase open while you are opening groove player ?
That might be a problem if your audio drivers are not multiclient .

Its a UAD Apollo Twin Mk2 on thunderbolt on PC, Windows 10 64 bit

If you change the interface samplerate, with Cubase open, a warning will come up - multiclient or not.

Yes if the samplerate changes, absolutely correct.
Some interfaces change samplerate depending on what you feed them, some don’t.
I didn’t think of that, I’m so used to my RME Raydat, playing anything with a different samplerate (Cubase open in the background of not) would simply fail unless the player uses an internal samplerate converter.
Thanks for clearing that up.