ASIO Spike first time a VST 3 plug plays fix

Re: ASIO Time Overload Issues

I’m re-posting this here just in case others have this issue and have not solved it yet, this happened to me the first time I turn on my pc and did not happen again once it payed the VST 3 for the 1st time then all was well yet it can return over time for some reason it’s a weird bug.

Postby shlomee » 08 Jul 2012 21:33
I solved this issue: I did 2 things and I don’t feel like seeing which one worked, feel free, I’m tired and want to play a little max payne 3 before bed.

  1. activate steinberg audio power scheme (doubt this was it, I already optimized my machine so try number 2 first)

  2. Goto File-Prefrences-VST(on the left side)-Plug-Ins-Uncheck the Suspend VST3 plug-in processing when no audio signals are received box.

For some reason a few of the VST 3 plugs when they play for the first time don’t like this setting and may cause an ASIO spike. I’m going to post this as a new topic in the forum as well just in case others are having this problem, with a modern machine this function is really not needed anyways.

Hope this helps others.

Shlomee

Thanks for the post. I too have been experience this problem, I will try your fixes and see if it works.

Best,

Jay

yeah it should be happening for most people, again a lot of people will ignore it because it is usually a one time thing it’s just good to know you can fix it, you can always turn the function back on if the added CPU use of not suspending the VST 3 causes trouble. For me I would rather have glitch free playback and recording than more power that’s just me.