ASIO spikes during ramp tempo change?

I recently started having problems with ASIO spikes when using the tempo track and a ramp tempo change. I use tempo changes on a regular basis and never noticed the problem before, but maybe it existed but was never bad enough for me to hear a click.

Has anyone else experienced this phenomenon? Is there a fix? Right now the only thing I can do is raise my buffer from 128 to 256. I don’t know why I need to do that all of a sudden - I have updated a couple VST’s but when I remove them I still get spikes. The spikes aren’t bad enough to cause a click, but they’re still there. Like I said, maybe the spikes were always there but I never noticed because they weren’t bad enough to cause a click but the updated VST’s push it over the edge.

So, anyway, does anyone else get ASIO spikes during ramp tempo changes?


Are you using an audio clip in musical mode or an effect that is sync’d to the tempo? The continuously changing tempo creates a lot of workload for the processor in these types of cases.

I too have the same issue so am very much interested if there is a performance tweak to remedy this. I run at a 256 buffer size and in large sessions using networked VEPro servers across three machines, tempo changes wreck havoc on my system causing pops. When I do a non real time export everything sounds great but live playback is a problem.

No system specs. No knowledge of possible causes of this type of problem. OP and “+1” person very low post counts.

If there’s no professional description and system specs such as you would supply a normal bloke like a plumber or mechanic then there’s not very much anyone can do to help.

“Summat’s up! It must be Cubase.”
“+1 I get this too so it’s definitely Cubase.” :laughing:

Doesn’t tell anyone a lot. Well, not about Cubase, but we’re not supposed to say what it says about the “user”. :mrgreen:

Sorry new to this posting problems thing.

Mac Pro 8-Core Intel Xeon OS 10.6.8 12GB of Ram
Cubase 6.5.0 Build 102 Running in 64-Bit Mode
M-Audio Fast Track Ultra

Good. Thanks. As you use a Mac could it be a Mac only problem? RGames?

Richard, I also have had this problem. No buffer setting seems to affect it. I’m using Quadcore Intel PC 32bit with maudio firewire interface.

Basically, anything within the ramp area is audibly scratchy, albeit only on some specific instruments, like expressive ones. To work around, I’m linking editors, then physically moving corresponding events in time for the tempo transition phase (instead of using the ramp), then jump tempo change to the new tempo. Or, in other words, as in the case of a slow-down ending of the song, no tempo track needed.

I know, it’s not as cool as if the ramp would just did it’s job!


I’ve been in contact with the VEPro guys and they are looking into it with the kontakt guys. They said they will reach out to the Cubase engineers if they need to. So stay tuned. In my case I only have this problem with Kintakt instruments in VEpro. All other plugins in VEPro work fine. I also know that DP using Audio units with VEPro and kontakt works flawlessly. So it’s something with Cubase, VEPro and Kontakt.

Has anyone stumbled across a solution to this problem? Do changes to Cubase or kontakt or VEP settings help? Increasing buffer size only helps a little here but doesn’t solve the problem (and makes live playing difficult do to increased latency).


I, too, have been suffering from this issue. I have been in touch with NI but they haven’t been able to find a solution to the issue. Removing the tempo sync in Kontakt instances does alleviate the issue, but it is not a good solution.

I just had a breakthrough. It turns out that removing Altiverbs from my project remove all clicks and pops issues. Can anyone with this issue and running Altiverb possibly try this? No amount of tweaking to Altiverb’s settings seemed to have any effect on the outcome. Other reverbs don’t exhibit the same issue.



Not sure if Altiverb had to do it, but I am no longer plauged with this issue. I recently replaced all my Alitverbs with new Algorithmic Reverb in Cubase 7.5. Soon after this change I noticed my tempo changes did not cause any spiking, popping or crackling. I can ramp and jump tempos with no issues now.

So much happier!