ASIO spikes

Yes, I have a problem with VST spikes as well. If the VST meter is around 50%, I have the problem that it will often spike to overload even without anything playing. You can just watch the VST meter hover at 50% with playback stopped and then spike to overload for an instant.

Also, playing a note on a VSTi can trigger this where it will overload for an instant but then playback for the remainder of the note is totally fine, even if you keep playing for 30 seconds. So that doesn’t seem correct behavior either.

The problems seems to worsen as you increase sample rate.

On Mac here BTW.

Does the CPU-spike behavior change when you check/uncheck the preference ‘suspend vst3 plug-in processing when no audio signals are received’ ?

Another thing, when your system is in a state of creating CPU-spikes again, please switch off every single plug-in one by one. If one of them is fighting with some bad numbers the spikes should stop immediately. May be this helps to identify the source of the problem.

Thanks for reply and suggestions, I will check activity monitor for RAM shortage and general RAM distribution (good suggestion), UAD level is reading 65% or so, I remember an earlier problem with ASIO spikes occurring with UAD-1 (and 2?) approaching it’s processing power limits on Macs, but I thought it was solved with UAD updates and 65% isn’t that high. Regardless, I will test by removing UAD-01 altogether, will also run Memtest to check for bad RAM. -will report back

I’ve been working at same sample rate (44.1) so have not noticed anything in that regard although that may be a big clue in solution, I have had similar things happen when working with VSTis.

For me, the performance meter is in constant state of flux, jumping between say, 30% and 70% with spikes lighting up the overload light occasionally (that’s when the dropouts occur), when as before (when my system was stable and I assume is normal behavior), the performance meter would only fluctuate when I added new plug ins or VSTis, as well new tracks or other things that would draw CPU power. The way it is now is that it is a constant state of fluctuation, never staying still even when idle (not playing or recording).

When switching to Cubase 6, I did make a lot of changes at the same time. I switched from a bootcamped XP version of Nuendo 3 (very stable and much better performance) to Cubase 6 on Mac OS 10.6 and also added N.I. Komplete (including Kontact) all at the same time. Also I added another 4 gigs of RAM. By all reports, I thought it safe to do this but I know that is a lot of moves to make all at once.

When seeing hungaristan’s (original poster) post, it seemed so close to my problem even though he’s on PC, that I had to chime in as I was about to create a new thread of my own describing the problem. Sorry, Hungaristan, I did not mean to take over your thread but our problems may be related. I have some serious testing to do and will report back with results,along with other suggestions, I’ll also try trashing prefs (it seems a lot more complicated than it used to, at least on mac, as there are a lot more to pick from and I’m not totally sure which does what.

This may be an important clue as it seems something is building up as continued work on the project goes on. I’m certainly not a programmer but “memory leaks” or “buffers not releasing” comes to mind.

Thanks, Stephen

-will try

I think I’ve done this but will do again. Does switching them off in the insert section of the inspector, project window or the Audio channel settings window have the same effect as removing the plug in altogether from the track?

Thanks

Hi hungaristan!

I.
On my system the ASIO spikes build up gradually. Everything seems to be ok on opening the project, but after a while I get more and more crackles. Quitting/relaunching Cubase helps for a while until the problem gradually builds up again. It seems as if something had to be flushed by quitting to get rid of the crackles.

The VST meter shows ~75-80% usage (which is another annoyance because the CPU load never goes above 15%), the memory usage is less than 40%.

To me it sounds like your system is going into some kind of energy saving mode. As if the cores gradually toggle down because they don’t realize that they are needed.

So you should try to turn off the AMD speed throttling technology “Cool’n’Quiet”. You can do this in the BIOS of the system. When you restart the system it will tell you in the beginning how you can acces the BIOS. The location of this setting is BIOS specific so I can’t tell you exactly where it is. What other CPU options do you have in the BIOS?

Here is some more broadband input from my side.
I have a couple of suspicions but im not sure.

It would be good if you could answer my questions and go through the points.
It does seem like alot but if you start going through this right now you will be done in probably less than an hour and the problem could be solved.

  1. Did the system ever run smoothly?

  2. Did you have this problem before 6.02 or only after you installed the the 6.02 patch?

2.Does trashing the prefs help?
removing-the-preferences-of-the-sequencer

  1. You are running Cubase 6 32bit on Windows 7 64bit right?

  2. Do the occureneces varry if you change “Devices–> Device Setup–> Multi Processing”?

  3. Do the occureneces varry if you change “Devices–> Device Setup–> Activate–> Activate Steinberg Audio Power Scheme”?

  4. Are you using the latest updates for your NI Plugs and UAD Soft and Hardware?

  5. Are you sure that you went through all the points in
    optimizing-windows-for-daws” or are there some that you are no sure about and if so which ones are you not sure about? It would be could if you could go through that list again and realy confirm what you have done.

  6. Could you create your projects on another position of your hard disc? Please also try to use another partition or even another disc. External hard discs should in some cases not be used as working medium, particularly if USB 1.0 is used.

  7. Could you temporaraly deactivate all device drivers that you do not absolutely need to run the system? This would involve for instance, Display Card, UAD, network card, bluetooth, wlan, etc.

Gr,
JHP

  1. Did the system ever run smoothly?

Yes, until the latest updates (v6, v6.02)

  1. Did you have this problem before 6.02 or only after you installed the the 6.02 patch?

They started on v6

2.Does trashing the prefs help?
removing-the-preferences-of-the-sequencer

  1. Do the occureneces varry if you change “Devices–> Device Setup–> Multi Processing”?

  2. Do the occureneces varry if you change “Devices–> Device Setup–> Activate–> Activate Steinberg Audio Power Scheme”?

Haven’t tried yet

  1. You are running Cubase 6 32bit on Windows 7 64bit right?

Yes

  1. Are you using the latest updates for your NI Plugs and UAD Soft and Hardware?

I’ve checked and there are some NI updates. I must install those before trying anything else because I discovered that the spikes seem to disappear if I open a second Kore 2 instance, load 3 of the 7 instruments into it and delete the same instruments from their original location in the first Kore 2 instance. It looks as if Kore 2 had some load balancing issues and 7 instruments in 1 instance would be heavier on the system than the same instruments distributed between two instances.

  1. Are you sure that you went through all the points in
    "> optimizing-windows-for-daws> " or are there some that you are no sure about and if so which ones are you not sure about? It would be could if you could go through that list again and realy confirm what you have done.

I’ve checked and they were all set.

  1. Could you create your projects on another position of your hard disc? Please also try to use another partition or even another disc. External hard discs should in some cases not be used as working medium, particularly if USB 1.0
    is used.

  2. Could you temporaraly deactivate all device drivers that you do not absolutely need to run the system? This would involve for instance, Display Card, UAD, network card, bluetooth, wlan, etc.

I don’t think this has anything to do with my problem for two reasons: the project has no audio just a few MIDI tracks to drive the VSTis and my data is on a 8 HD RAID array with a dedicated RAID card. The disk throughput is enough to handle some heavy HD video projects, so audio should never be a problem.

  1. Could you temporaraly deactivate all device drivers that you do not absolutely need to run the system? This would involve for instance, Display Card, UAD, network card, bluetooth, wlan, etc.

I’ll leave that last.

It’s okay as long as you’ll mention my name in the credits and will issue a statement that this thread is my intellectual property :slight_smile:

…sorry that I cant help, and I am sorry to hi-jack, but I just had to chime in on this one as I am struggeling with the same problems/symptoms. Everything started when I upgraded to Cubase 6, and got even worse in 6.02.

Win or Mac?
NI?
UAD?

It would be nice to spot the similarities between the problematic systems. Eg. I noticed that smartinuf has Kontakt in his project and Kontakt is one of the Kore 2 instruments in my project, too. I have a suspicion that the problem might be related to using NI (see my previous post about using multiple Kore 2 instances).

OK, went to studio today to perform tests, troubleshooting, etc. Brought up same file I was having problems with, as described earlier. System performed as it should, no asio spikes, performance meter hung around 10% as it should for a project this size. Asio buffer at 256.

As I only had an hour or so, I decided to get a mix of the song while it was working right as I don’t know when it will screw up again.

This has been the nature of this problem all along and part of what makes it so elusive. I have a feeling that if I had kept working on the song it, it would have crept back in as in the case of the other night when it got real bad and I couldn’t even play it through without tons of spikes and dropouts. That night, I was working for at least 6-7 hours and should report that I did not try quitting Cubase and restarting which as Hungaristan reported seems to help almost as if a “reset” was performed.

I did notice that the preference for “suspend VST3 processing when no audio signals present” was checked initially.
I tried unchecking it and nothing n changed but as I said problem was not exhibiting itself in the first place.

Also, the other night when the spikes were occurring, I opened another project that contained NO VSTis and the problem persisted though not as bad. There were also many less plug-ins installed.

Since I had limited time and the problem was not showing itself, I could not perform any other tests, I’ll try again over the weekend when I have more time perhaps from the angle of trying to induce the problem if I have to.

I should also report that I don’t recall making any setup changes other than trying different buffer settings over the course of the night when the problem was showing. I did of course make edits,EQ changes, etc., as I was attempting to mix. As for the buffer settings that night, I believe they were at 1024 to start with and after trying many settings in my troubleshooting experiments must have ended up at 256 as that is what the project opened with today.

I wish I had more to report, this is frustrating but I’ll keep trying.

Thanks, Stephen

@Hungaristen
Yes Kore has some things to take in account. (use it myself). Kore has no multicore support. If you run everything in one Kore it will all be loaded on one cpu core so if you have a 4 core cpu use at least 4 Kores too (or one for each sound) Plus. Kore is inefficient itself cpu wise. If you use a massive sound for example in Kore, it will have more cpu useage if you use the patch in Kore then just the massive plugin. Plus that way (using for example 2 Kores, 2 massives and 2 absynths etc) the multicore usage of cubase is better then in less instances. Memory use might be slightly higher but not much.
Hope this helps
Vincent

You missed this one and really should try it: “You should try to turn off the AMD speed throttling technology “Cool’n’Quiet”. You can do this in the BIOS of the system.”

For those with Intel chips the equivalent move would be to turn of speed stepping, also called EIST, in the BIOS

To 6:
There where Multicore issues in the past with NI plugins and also with UAD in conjunction with Cubase. So updating would really be wise.

To 9:
Ok, leave it last but if the problem persists realy go back to this. Really disable all of your devices in the Device Manager and don’t be contained when doing so. Display these devices: Soundcards, Display Card, UAD, network card, bluetooth, wlan,

And then check if the problem persists.

To 8:
Regarding your 8 HD Raid system:
Hmm I’m a bit worried about that. I’m not too familiar with such a setup.
Which RAID level are you on? RAID 0, the duplexing mode?
Or are you using a mirroring level?

Gr,
JHP

I forgot to add this, but this was already done a year ago when I set up the machine.

To 6:
There where Multicore issues in the past with NI plugins and also with UAD in conjunction with Cubase.

To me this seems to be the most likely cause. Again, this machine with the same components used to run without any hiccups for nearly a year. Software updates (no new software) were the only changes that were made during this time and the problems started with v6.

But do you still have Cubase 5 installed right now right? Do the problems occure there as well?

You should still not jump to conclusions and continue to try the other suggestions from A to Z.
Do update your devices and do everything I have suggested. You will be past that in less than an hour.
Here I already looked up the page for your mainboard check the updates:
http://www.supermicro.com/Aplus/motherboard/Opteron2000/MCP55/H8DA8-2.cfm

To 6: Let us know what happens when you update you UAD and NI plugins.

Check if the affinity trick works:
When the problem occures go to taskmanager (Contr+Shift+ESC) --> Processes–> Right click on Cubase.exe–> Set Affinity --> Click on Ok (You do not even have to change something in the affinity dialog)

Gr,
JHP

My system:
Win 7 64 bit
Cubase 6.0.2 32 bit
Dual core 3.16ghz
8 gig ram
UAD2 and UAD1

I am running projects with EWQL Goliath, and Halion Sonic… These projects worked great until I installed Cubase6.0, and got worse after 6.0.2. But the funny thing is that it seems to get worse every day?! I really cant play my projects anymore…

OK, so we both run Cubase 6.0.2 32 bit on Win 7 64 bit and for both of us the problem gets gradually worse. Now I’ll install the latest NI updates, go through the actions recommended by JHP (check his latest post) and report back.

OK, me too.
I’ll finally have some to devote to this (if the universe cooperates) tonight (6/11) and will attempt to edit and mix another song from the same live session as before and troubleshoot along the way. I’ll be the Mac guy, maybe we can narrow this down further, platform-wise or whatever. I’d like to encourage anybody else (Robotpriest?) with similar problems to participate however they can. Also, thanks JHP for contributing and watching this thread.

Stephen

I’m not sure it’s as simple as that. The CPU meter shows an evenly distributed load between all 12 cores at a very low level (~10-12%) and there’s no sign of loading one core only. However, using multiple instances of the instruments definitely seems to help.

I have the same audio clicks when recording 12 tracks at the same time. I never had this problem before using cubase (from SX3 till 6.0) The problem appeared on version 6.0.2.

No VST’s are activated. Only audio through Scope Asio drivers.

I’m beginning to think I may have a RAM problem (Thanks NYC). My system is only reporting 6 gigs of RAM when it should be 8, probably a bad stick. System profiler reports ECC errors on one stick. I’ll try reseating and reconfiguring slots, removing, etc. I’ll report back when I can definitely confirm but it may take a few days as time is limited.

I would recommend others with this problem check this angle as it makes sense in a few ways, cross platform, heat related as in build up of heat in computer over time hence more errors with longer use and reset on startup not to mention weather in general.

Please report results, maybe we can let Steinberg off the hook on this one, ha.

Stephen