ASIO spikes

My system:
Win 7 64 bit
Cubase 6.0.2 32 bit
Dual core 3.16ghz
8 gig ram
UAD2 and UAD1

I am running projects with EWQL Goliath, and Halion Sonic… These projects worked great until I installed Cubase6.0, and got worse after 6.0.2. But the funny thing is that it seems to get worse every day?! I really cant play my projects anymore…

OK, so we both run Cubase 6.0.2 32 bit on Win 7 64 bit and for both of us the problem gets gradually worse. Now I’ll install the latest NI updates, go through the actions recommended by JHP (check his latest post) and report back.

OK, me too.
I’ll finally have some to devote to this (if the universe cooperates) tonight (6/11) and will attempt to edit and mix another song from the same live session as before and troubleshoot along the way. I’ll be the Mac guy, maybe we can narrow this down further, platform-wise or whatever. I’d like to encourage anybody else (Robotpriest?) with similar problems to participate however they can. Also, thanks JHP for contributing and watching this thread.


I’m not sure it’s as simple as that. The CPU meter shows an evenly distributed load between all 12 cores at a very low level (~10-12%) and there’s no sign of loading one core only. However, using multiple instances of the instruments definitely seems to help.

I have the same audio clicks when recording 12 tracks at the same time. I never had this problem before using cubase (from SX3 till 6.0) The problem appeared on version 6.0.2.

No VST’s are activated. Only audio through Scope Asio drivers.

I’m beginning to think I may have a RAM problem (Thanks NYC). My system is only reporting 6 gigs of RAM when it should be 8, probably a bad stick. System profiler reports ECC errors on one stick. I’ll try reseating and reconfiguring slots, removing, etc. I’ll report back when I can definitely confirm but it may take a few days as time is limited.

I would recommend others with this problem check this angle as it makes sense in a few ways, cross platform, heat related as in build up of heat in computer over time hence more errors with longer use and reset on startup not to mention weather in general.

Please report results, maybe we can let Steinberg off the hook on this one, ha.


OK, so after installing all NI updates AND distributing the instruments evenly between two KORE 2 instances instead of using a single one the ASIO spikes have gone and the ASIO load dropped back to 40-50% from 70-80%.

It would be easy to blame NI only, but the problem didn’t show up until v6, so it’s not as simple as that. Anyway, it’s working now.

Ok, so the issue has been solved after updating the NI plugins.
To the other participants, let us know how your cases develop.


It seems many people have the same problems, and I have been one of them. The ASIO would spike red and produce skipping clicking sounds.
I am using Windows 7 64-bit with Cubase 6.0.2
Recent Windows 1394 driver are the problem. It started with XP service pack, and continues with Win 7.
The earlier windows drivers allowed the firewire to communicate at speed of 800, but the newer drivers won’t sync above 400.
Go to device manager, find your 1394 device and Update driver manually (downdate).
This is done by right-click on the 1394 device…Update driver software… Browse my computer for driver software…Let me pick from a list of…
One of the descriptions that appears in the list will have (Legacy) at the end of the line
“1394 … (Legacy)”
Select that one. Reboot, breath, drink…
For me all spikes, nods, winks, and red lights stopped appearing, as well as the reported Latency statistics in Cubase device setup dropped by half.
Hope that helps


Forgive my ignorance, and I’m probably going to look like an idiot posting this, but… are you using a firewire 800 interface? I’m only using a firewire 400 interface (M-audio profire 610). I’m sometimes having ASIO spiking issues as described in this thread, but it seems I’ve been able to clamp down on them a bit by turning off some background processes in windows etc. Even so, it still seems to me that plugs like Halion Sonic use an awful lot of CPU power, though, and I’m still having occasional spikes and dropout issues with Kontakt 4.

Anyway, I can’t consistently reproduce these problems so I’ve been keeping quiet and trying to figure it out on my own. I’m all for trying your firewire driver suggestion, but I’d gather most of us are using a firewire 400 interface anyway, so I’m confused as to why the latest drivers bottlenecking the firewire 800 to firewire 400 speeds would make much difference. I’m not arguing… just trying to understand.

Good evening Ladies & Gentlemen!
First off: Sorry my English…

I want to thank all the Users for their answers with this annoying issue and have to say that every help wasn’t the cure for this issue! I fought 4 days with that problem and searched all over the internet for a solution! I’ve tried nearly everything and I can now tell you what is “not” the problem!

Here’s a summary what Users all over the world told the victims:

-Too short Buffer Size (Nope it is’nt, it is a subtle change but over time it grows bigger…)
-Multi-Processor support and other options in the settings (Nope, the same problem)
-Wrong Soundcard Drivers (Nope…)
-Wrong Firewire Drivers [NEW & Legacy etc.) (Nope, I’ve tried them all)
-Give another Firewire Port a try (Nope - I’ve tested onboard and the PCI card. Same problem)
-Cool ‘n’ Quiet and other lame stuff from AMD MB’s (It was an issue before C6 but “This” issue is something different with similar symptoms.)
-Conflict with other Drivers (Nope - I deactivated everything which was onboard etc.)
-Dirty OS (Nope - New/Clean installation)
-It’s the combination between W7 64 Bit and C6 64 Bit (No!! Unfortunately… It is’nt, I was running C6 32 Bit on that platform and got that same issue again…)


-There was absolutely “NO” problem before I bought C6! I’ve used C5 and downwards with loads of tracks and plug-ins etc. and that with my “old” PC!

-I’ve bought a new one because my new libraries which are craving for “more” 64-bit power - so I’ve built a computer with an AMD x4core 3,5GHZ, 16GB DDR3 RAM, Windows 7 64 bit, C6 64 Bit etc. My interface is a RME Fireface 400! It worked very well with my old PC. Even with my mobile interface (M-Audio Fast track pro) I don’t got this problems (On C5)…

-I’ve paid a lot of money for all the things (>1000€) and the only thing I can do now is switching to my old system, which is “now” the only solution, (Without the use of my Librarys etc.) and hoping that an update finally fixes that problem…


You don’t seem to have tried this and in my experience it’s the one you should have done first (hand-in-hand with turning off power-saving in BIOS). I have noticed that since this option was introduced in C5.whatever-it-was, after upgrading it was always wise to check it hadn’t defaulted back to off. I seem to remember that the C6 version of this option is slightly different so I would check.

You definitely need it, it stops Windows from throttling the cores back and what you describe is a classic symptom.

[Edit] Just read the latest post, which appeared while I was writing this one. It’s not Cubase, it never is, lots of people have it working fine, including me. But it took some getting there and it involved having to learn a lot about BIOS, hardware and power modes. That’s where you are, my friend. Sorry… :slight_smile:

Thanks a lot for remembering us to do this!
It cured the ASIO spikes and audio crackles I had on both Cubase 6.02 versions (64 bit and 32 bit) after a migration from Cubase 5 on Windows XP to Cubase 6 on Windows 7 64 bit.
And indeed this option was per default deactivated in Cubase.

Best regards

I’ve activated Steinbergs Power Scheme. No change!


That’s unusual! My CPU is Intel i7 (also a 4-core) so I couldn’t tell you exactly what you need to set your BIOS up properly. Maybe you should post up your settings so someone can take a look.

In the meantime, could you launch Cubase with the Steinberg Audio Power option ticked (and Use Multicore) and then, while it’s running, go to Power Options in the Windows CP and make sure that the current power scheme is indeed Steinberg Audio Power.

Assuming it is, click “Change plan settings”, then “Change advanced power settings”, which opens the Power Options box. Scroll down to “Processor power management” and make sure “Minimum processor state” is at 100%. This is the key setting and if the “Steinberg Audio Power” setting isn’t working for some reason, you can set up your own Power Scheme with the above processor setting and enable it before running Cubase. It’s only a workaround but what you had to do before the option was added.

Let me know how you get on.

Good luck,

Just occured to me you might have something running in the background that is eating up CPU cycles. Anything obvious in your System Tray? Another place to check is Windows Task Manager. Open it up and click the Processes tab. Click the CPU column to sort by it and see what comes out at the top. Do the same for the Memory column. This may point you at something useful.

Also, shed-loads of Services will conspire to slow you up and there is a good chance you won’t need them all. I managed to cut mine down substantially but you must tread carefully so it’s probably best to leave the next step until you’ve had a look.


@Xenu - by any chance are you running Native Instruments VST’s? If so, it well documented that Reaktor, and from what I’ve read Kontakt also, cause ASIO spikes and has not yet been fixed by NI. This doesn’t seem to be an issue for any of the other Komplete 5 instruments I use such as Battery, Absynth, Massive, FM8, B4II, etc. I don’t use Kontakt but I use Reaktor and to fix the ASIO spikes the two most common solutions are to change your buffer size, say from 128-512, then back to what you originally had it set to. In addition, also go into Devices - Device Setup - VST Audio System and set the “Audio Priority” from Normal to Boost. This fixes the problems for me but this has to be done each time an instance of Reaktor is loaded - even when Boost is already set. You’d have to switch it back to normal then boost again to stop the spiking.

If you’re not running any Native Instrument VST’s then sorry this info may be of no use.


I’ve deactivated everything from the powersucking features of that motherboard and also every service which I don’t need! (Really everything like Networking/Security/RPC/Search/Design etc.) I’ve tweaked nearly everything in W7! CPU is working from 0-1% @ Task Manager.

@Rev: Yeah I’m using Steven Slate Drums threw the NI Kontakt Player and Spectrasonics Omnisphere and Steinberg The Grand 3 which are craving for the most power, even when I don’t play anything… I heard of that Kontakt problem before but it was not so bad before my new system! It’s horrible to work with 2 Amp Simulator Tracks, SSD and Spectrasonics + 1 Vocal with compression and Bass Guitar! I have to freeze the VST’s and have to pull down the Buffer Size to 1024 Samples to work like in my old system… And even there it was better before with dozen of tracks… It’s a really pitty because I like the new features of C6…

Thanks to all for reading… That’s really kind!


I’m just chiming in to say that although I started this thread and later wrote that my problem got sorted out by splitting the load between using two Kore 2 instances instead of using just one, something is still wrong here. I can’t be more specific right now, because I had no time to do more thorough tests to figure out what exactly has to be changed to regenerate the problem, but it does occur from time to time. Once it appears, the only way to get rid of it is to relaunch Cubase. It’s not the power scheme and it definitely started with v6. I’ll get back when I find something more specific.

I get spikes even when my VST meter is only at 20% and playback is stopped. It will hover at 20% then overload for a second and drop back down. All without even playing. Something is definitely amiss.

on Mac here so no BIOS options, etc, available.