Asio Time Overload after installing Win7 64bit (Solved)

I just recently decided to install 64bit Windows 7 due to a RAM upgrade. After this I started to get Asio Time Overload on playback.

Computer specs:
Intel Core2 Duo 3GHZ

Sound: Echo Audiofire 4 (but same error with integrated soundcard)

I have tried to change buffer (all kinds of settings). I have tried DPC Latency Checker (it’s OK). I have done all kinds of recommended Windows changes to optimize, without any luck.

I have also updated drivers and firmware for soundcard.

Any suggestions (except reinstalling 32bit) is appreciated!

EDIT: Solved by reinstalling 32bit Cubase. Seems the 64bit was a so-called preview that followed on the CD. Seems it was a bit unstable.