ASIO time usage clip problem 5.5.3 W7 64 bit

Before I try customer support… here goes.

Built a new PC and kept my 3 WD caviar black audio drives. Everything else is new. C: drive has fresh install of Win 7 64 bit. w/ all updates and fresh 64 bit and 32 bit cubase 5.5.3 full version.

Problem: ASIO time clipping. In playback and/or recording of one track with no effects, ASIO time usage goes from 1% to clip every few seconds w/ audible tick in both 64 and 32 bit cubase.

My system:

MOBO Gigabyte Z77 UP4-TH
CPU: Xeon E3-1230 V2 (1155 Ivy bridge)
RAM: Corsair dominator 8 GIG 1600
HD: 3 WD caviar black 32 meg cache
PSU: NAXN 650w
Video: PNY GT 220
1394: SIIG DP firewire 2-port PCIe V2.0
Perifrial: 1 Mackie Blackbird (24/96k)
OP SYS: Win 7 home 64 bit
Cubase 5.5.3 64 and 32 bit

Optimization steps:

As cubase states on their web site it is meant to work with “normal” computers as long as the minimum requirements are met so I only did a few adjustments seeing that this is no slouch of a system. There is no blutooth and all updates have been done aside from bios update. These are some of the tips I found.

  1. Sys restore off
  2. firewall off
  3. internet disable
  4. power set max performance
  5. Cubase CPU energy saving off and multi processing on
  6. hybernate and screen saver off
  7. loaded legacy firewire driver
  8. disabled hyperthreading
  9. virtual mem. 0
  10. No secure sys running

Other thoughts: I tried to DMA: ON but SATA mode only works in AHCI and does not alow this option. There may have been a few other small tweeks I am forgetting. My system works great except for this one small problem. I set buffer as I would normally (256) do in my old 2 core AMD XP machine and even when I raise it it still clips. Also when I set ASIO to generic it goes away but at a latency of 40.0 ms not low enough for my use. I use to get 7-10ms with my old machine… What could it be?

There is a good chance it has to do with the various ‘C States’ in the Bios (I mean the UEFI)…
EIST (Enhanced Intel Speed Step) combined with Turbo Boost is oriented toward Gamers and Green energy usage; it is fine for most applications, but DAW is a different beast.
Basically, Turbo Boost increases the CPU multiplier whenever the processing load gets high.
EIST, C1, C3, etc, put the CPU into a low power state whenever the CPU load is light. Each via different methods, either reducing the CPU multplier & voltage, or shutting down a core or more, etc. The problem with all this is that Cubase wants to see a steady CPU ‘state’ and has problems when the multiplier is changing 100’s of times a second (literally, with Turbo Boost) and then is throttled down to some low multiplier / energy state when the processing load gets minimal.
You may want to investigate all this and then check your bios settings (I mean UEFI~!:slight_smile:
Of course your problem may be different altogether, but I just researched and put a similar system together and I noticed the bios defaults were set for gamers and overclockers, with ALL that stuff turned on; the CPU was going up and down like a YO-YO. Using Turbo Boost to get arbitrary high CPU speed (and the C States for cooling down & energy efficiency) is not so good for audio recording. Stability is more important.
Check this:

The OP, jschild, is Scott from ADK; they build DAWs for a living, day in and day out, so I’m guessing he knows what he is talking about. To sum up what I am getting at above, here is a quote from that post:

modulations in the system timer (even slight) could create
system stability issues

But that is just part of the issue. Go read that post; plenty of info (and a lot of arguing too :wink: )

Incidentally, it looks like you have a motherboard with Thunderbolt on it. Are you using the Thunderbolt port right now?
If so, you may want to check the mobo specs real close; I have the Asus Z77 V-Pro w/ Thunderbolt; I got it so I could use thunderbolt later when more devices are availble for it. But I noticed that the Thunderbolt bandwidth is shared with the 2nd PCIe X1, the extra Asmedia Sata 3 ports and the extra Asmedia USB3 ports. There are bandwidth limitations on any chipset; you have to pay a lot of money to avoid all that bandwidth and IRQ sharing (that’s why Steinberg recommends HP workstations that cost 3 - 6 grand).
The first thing I did was go into the bios and turn the Thunderbolt off, since I have no need for it now.
The same is true of any other ‘embedded’ feature you are not using on your motherboard: turn it off!
On the software side of things, the idea used to be about getting as much RAM availble as possible, but now, with 64 bit OS, the focus is more on anything that interferes with getting your DAW to as close to ‘real-time’ as possible. Anything that takes too many cycles or jams up the system is bad, and no amount of brute force processing power is going to solve that issue, so you need to know what is holding up your OS - literally holding it hostage for just long enough to make a low buffer DAW choke. For that, check out:
dpclat, the Deferred procedure Call checker at
Or better,
The first one is well known, but the 2nd actually tells you what programs or routines are holding up your system.
Good luck!

I should have mentioned that there is no need to worry about AHCI for the Drives; that is actually a faster method than the old IDE; DMA was a way of getting the most out of IDE, but with SATA, it is not really an issue. Is your disk activity indicator even moving? If not, your fine.

Even with 8 GB memory, it is inadvisable to turn off the page file. The OS will use it to some extent no matter how much memory you have; it will make one on the fly if it has to. Better to set a fixed size, and if you can, put it on another drive or partition. I used to make a 6 - 10GB partition just for the page file. That way it never gets fragmented.
If you get an SDD, put it there. I have the whole OS and a 2048MB page file + samples, etc on a new OCZ Vertex 3 Max IOP 240GB SSD and it flies! (SSD’s have their own issues though - turn off defrag; make sure there is a 1024k offset at the front, etc.)

What about the SIIG Firewire card and drivers?
Did you use that in the old system?
If you did and it worked fine, maybe it is a bandwidth (or IRQ) sharing problem, as I earlier stated. Turning off TH & other unneeded mobo hardware might help. OR:
Try putting it in another PCIe slot (you can even put it in a x16 slot, though it will probably knock your video card speed down to x8, but that might not be anything to worry about - I had to put one of my UAD cards in a x16 slot and my GTX480 is still benchmarking at the Windows maximum).
Is that (the Firewire card) your converter pipeline to the computer? That is a high priority point, and if anything is wrong there, you’re in ‘kludge land.’
If it is a new acquisition (or even if it is the same thing you used in XP/32 bit land), maybe the drivers don’t play nice with Win 7, or the 64 bit environment; you may have to try different drivers, or get a different card. Texas Instruments is the recommended Firewire chip to use. A lot of people have had issues with this in the past and found that their VIA or other Firewire chip was causing a problem.
Incidentally, I’m afraid that Firewire is being phased out. And I just bought a MR816CSX for my laptop! But USB3 and Thunderbolt should cover the new converters, though I like a solid PCI (e) connection when it comes to digital audio I/O.

Thanks for the thorough reply. I downloaded the second latency checker (resplendence) and it’s telling me there is a problem and to check for bios updates and cpu throttling. The firewire is new and it has the TI chip, thats why I bought it. They claim it works with win 7 64 bit. Their drivers come with windows, no updates. I dont have a lot of time but I’ll read up on what you linked and everything you suggest and post back later. Thanks again.

Problem solved. I went through the cpu power settings in bios and tried other tweeks but still asio spiked. The problem was a bloat-ware program from Gigabyte called easy tune 6, a program for overclocking. My bad letting that through. It was set to check the system every 3 seconds which was exactly when I would get the asio spikes. Hope this helps someone in the future. Now @ 96k my asio latency is 1.6 ms input and 3 ms out with internet on and no spikes.

Just a follow up. I still had some latency but the big problem was gone. I checked the highest executions with latencymon and it was nvidia @1.4. My graphics card PNY Geforce GT 220 1gig pcie 2.0 was really holding up my computer. I switched it with another card I had a EVGA geforce GT 520 2 gig … and that # dropped to .56. Today I put in a AMD radeon sapphire HD 5450 and all drivers under the highest execution list start with .0xx, graphics card not being near the top. Its a cheap way to improve your latency if you have a graphics card that isn’t staying out of the way.