Asio Time usage/spikes problems

Hi on very heavy projects im maxing out the asio time usage meter which is causing spikes. Now this happens only on very big projects with a bunch of vsts and i admit i use tons, which seem to build up the meter till it hits the roof. But i think the computer should b able to handle it since its a very powerful system-i7 990x, 24gb ram, win 7 64bit, soniccore soundcard running at 7ms latency
and i checked in task manager and is using around 60% cpu in these ideas?

You don’t say which Cubase, x86 or x64. Could be one plug that’s the culprit. Do you run J-Bridge?

It’s not as simple as a system being fast. You have to know what you’re doing and what resources are your bottleneck. Right off, 60% solid will likely get some overs. Lots of VIs–how many are disk streaming? Where are their samples? What’s the edit density of the audio? The resolution? Are you asking the VIs to real time resample their outputs to a rate other than their native sample rate? Is 7ms realistic for all you’re asking of the system? That is why you’re getting overs–you bump your buffer higher, they will likely go away…and your latency will be higher–lower is hardware on the CPU…not terribly related to the sound card itself, save maybe driver efficiency.

Anyway, just because you think it should be able to handle whatever you want to do doesn’t make it so. Particularly with VIs–cutting edge VIs can thrash a system in no time. Particularly of you don’t understand the necessity in system design of drive configuration and cas latency of RAM. I can produce 24/44 audio on a decade old P4 just fine. And I can bring my core2quad to its knees with VIs combined with low buffer settings. VIs drive the need for faster computers in music production, IMO…that way games drive graphic card markets.

im using cubase 64 bit 6.0.5, 44.1 32 bit float, all 32 bit plugins using jbridge.
It doesnt seem to be any one specific plugin. When scrapping all the vst instruments in the project, the meter is still hitting cieling, and as i slowly remove audio tracks the meter goes down, so looks like its the accumulation of all the plugins building up the aiso time usage,coming mostly from fx like waves plugins. I tried changing the buffer size but cant seem to be able to get to it. In device setup, when i click on the control panel button nothing happens :question:


If Cubase can’t open it then you need to do it directly from the Soniccore (Is that Scope?? I thought the whole idea of that was DSP processing to save cpu!) software control panel before opening Cubase.

Upping the buffers ought to give you a bit more headroom…try 1024 or higher & see if it helps. Another thing to look at is how your individual cores are loading. In windows task manager tick the show all cores box to see if any one core is way higher than others.

Basically though I would say that 60% overall cpu useage is not that bad & you are probably reaching the limit of your system at it’s current ASIO buffer settings…you have to accept that the asio will overload before the cpu reaches max.

thnks it was indeed in scope, didnt have buffer size settings but latency times which i now found is what changes the buffer size, like 4ms=128,7ms=256… i switched to the highest latency setting-25ms, which lowered the meter slightly now no spikes but looks like a few more plugins will get it there again,i was hoping meter would b lowered a lot but only seeing a slight improvement gets me wondering if theres any kind of mod or anything i can do to give more headroom?? spent alot of money on building this computer hoping to be able to b free from the creative boundaries not expecting to run into a different wall…

and i cheked btw looks like all cores workign fine,