ASIO4ALL, Win 11, Cubase 12

I use headphones via audio Jack .
I will make some tests tomorrow.


Looks like Realtek offers 2 audio output pairs on your computer. Are you sure HAP is the correct one? Otherwise change it to 2nd Output in the ASIO4ALL control panel.

1 Like

Ive also tryed 2d output.

Somehow Ive forced to work FlexASIO driver… I hope it will work fine

I didn’t know other asio4all like drivers existed… Thanks for mentioning it.

Also, it would be worth adding your system specs in your forum profile. This will help other users give more relevant replies. Follow the following guide for this:

Thanx for your advice.

1 Like

Just tried it. It doesn’t have a control panel UI. Also, latency is 60 ms and the headphones output doesn’t show on my laptop :thinking:

Yes, it doesnt have control panel, but it works at least :wink:
I switch to headphones via Realtek “pop up menu” under speaker icon…
a bit annoing but it works

1 Like

Thanks for the tip, it works!

1 Like

According to the info found on Github, the way to adjust the latency is as follows:

  1. Open Notepad and enter the following

backend = “Windows WASAPI”
bufferSizeSamples = 480

[input]
suggestedLatencySeconds = 0.0
wasapiExclusiveMode = true

[output]
suggestedLatencySeconds = 0.0
wasapiExclusiveMode = true

The bufferSizeSamples parameter should be adjusted to achieve the best ratio between minimal latency and CPU load.

  1. Save the file as .toml in the following location (the folder where user’s “Documents” folder is located):
    %USERPROFILE%\
1 Like

You’re welcome :slight_smile:

Thank you.

Yes thanks. I was already trying that. Now I get a 10ms latency. :+1:

2 Likes

Also, apparently there’s a 3rd party configuration GUI available here. But I can’t find a way to install it. The installer is a .ISS file. I’ve tried to compile it through Inno complier but I get error messages.

Its version for International Space Station :wink:

:joy:

Seriously, it should be an Inno Setup Script. See here . When compiling I get a "no files matching "C:..\bin\x64\Release\net6.0-windows" error . I’ve downloaded and installed .NET 6.0 though… Well, I think I’ll give up…

I wonder if FlexASIO will work with the Behringer UMC22 interface… I don’t remember if it has its own driver or only uses Asio4all. I have no way to check it right now.

dont give up