Asterisk appears for no reason on render presets

PG, here’s the other problem that hasn’t gone away in 7.01. Unfortunately, I haven’t figured out how to reproduce it reliably. But it happens to me about 25% of the time I render a file.

For example, let’s say a client hears their mastered files and orders me to “turn it up” . I load up all the mixdown files, load the master section preset for the first file, adjust the limiter, and render the file using my “24-bit .wav” setting (Wave, PCM (uncompressed), match, match, 24-bit, Untitled). Select the next file, load the appropriate master section preset, adjust the limiter, and now the render dialog shows an asterisk next to the preset name. Of course, I haven’t changed anything! But I always re-select the preset just to be sure.

Any ideas? Can you think of a way I can reliable reproduce it? Just for kicks, I loaded in the mixdowns for an album I recently mastered. I re-rendered the files one at a time, without changing any of the settings, and the fourth time the asterisk appeared. From what I can tell, it’s completely random.

Any help would be greatly appreciated!

You are speaking about the file format preset, not the Master Section preset, right?


What are the exact settings of your preset then?

About as boring as anyone could hope for:

Type: Wave (Microsoft)
File extension: wav
Audio format: PCM (uncompressed)
Channels: Match input stream
Sample rate: Match input stream
Bit resolution: 16 bit
Attributes (meta-data): Untitled

The only thing in the master section is dither: Intern, Noise Type 2, No Noise Shaping, 16 bit. There are no effects or gain changes.

A File Format preset is independent from the plugins or dither.
I tried to reproduce your issue without “success”.
To make sure we speak about the same thing, next time this happens, please make a screen shot of the concerned window where this name+asterisk happens. Thanks.

Here is a full screen grab. It happened on the fourth file I tried to render:


Oops, I guess I shared the wrong preset details above. It’s the same except for the bit resolution, which is 24 bit. It happens with my 16 bit setting too though.

Hi PG,

I made a screencast so you can see it in action (be sure to click the fullscreen button). It happens here on the fourth file. Well, and technically the first, since I hadn’t changed anything before starting the screencast.

Maybe the Algorithmix PEQ Red plug-in has something to do with it? When I render, maybe 25% of the time the plug-in has an issue, so I have to reload the preset and try again.

Whatever the cause, it’s very annoying! I always go back and re-select my standard 24-bit preset just to be safe, even though I know I haven’t changed anything. Between that and the PEQ Red crashes, rendering files from presets can be a real chore.


Thanks for this excellent movie report.
This gave me an hint. I can reproduce this issue, but if and only if, the 4th file has some meta data.
And then there is a logic behind the asterisk, though the design could be improved.
Let me explain:

The 24-bit preset has no Meta-Data. But the Audio File has.
WaveLab, by design, will preserve the meta data of the original file.
This means your 24-bit preset is temporarily set with Meta-data, and this becomes the active preset.
Since this is different than the original preset, an asterisk appears.
Hence there is a logic behind this.

Now, this logic is not intuitive for sure. I have to do something for next version, like maybe adding “Match input file Meta-data”


Interesting! That makes sense, because the first and fourth files brought up the asterisk, while the second and third didn’t. You can see in the upper-right corner of the screen that 1 and 4 have metadata, and 2 and 3 don’t.

I’m only seeing metadata related to the artist name and software used to render the file. Are you saying there’s also metadata for the file format? In other words, if it were a 16-bit file with metadata, would it change my output settings from 24-bit to 16-bit? If not, is it safe for me to ignore the asterisk?


Meta data in independent from the audio contents. This won’t affect the bit resolution in any way.

So does a file’s metadata have the potential to change my preset in any way, or is the asterisk simply a mistake? If so, I’ll just ignore it.

The asterisk is more a design mistake than a real mistake. Because it displays one thing: the file is not going to be saved with a null meta-data, as the preset implies it.
This means, if you save your file while the asterisk is displayed, the audio properties will be the one expected, and the meta-data will be the one of your source audio file.

Oh, now I understand! In that case, I’ll go ahead and re-select my preset to wipe the source file’s metadata. Some sort of toggle would be useful in the next update!

Reloading or note the preset won’t remove the meta-data. The meta-data will stay. This must change in next update.

Got it. At least that will save me the hassle of re-selecting the preset.