Atonal key change in condensing

The atonal key signature is shown in the non-condensing view, but not in the condensing view (horns excepted, for some reason).
Is there something I can do about that?

Atonal non-condensing
Atonal condensing

Can you cut your project down to a few bars either side of the change of key and attach it here?

Here it is. Thanks for offering to take a look.

Legend of the Lake, few bars.dorico (1.5 MB)

You appear to have entered all the key changes as local key signatures.

Turn off condensing.
ctrl-click select every key signature. Delete.
Re-enter the key signature shift-k C enter.

Turn condensing back on.

2 Likes

Janus, you are my saviour on this project! Many thanks!

1 Like

The score is a MusicXML import. Iā€™m afraid I forgot to check any key-signature options before importing. :roll_eyes: