Audio being stretched on import, please help!

Im trying to import vocals in a .WAV file but it is stretching the vocals somehow (playing way slower and lower pitch). My friend exported the vocals at 48khz sample rate and 32 bit float but my project was in 44.1khz by default. Ive tried changing the vocals to the same sample rate as my project but it is still off, also changed my project to match vocals but no result. The vocals are fine when i play the .Wav file on media player

I sent him the beat at 110bpm as a wav and he recorded at 120BPM, ive tried changing BPM’s also but cant seem to get it to match.

Im fairly new to production and not qite sure what the problem is, any suggestions would be much appreciated.

Hi and welcome,

Enable the option to resample the file while import. And make sure your Audio Device Sample Rate matches the Project Sample Rate, please.