Audio Configuration

Hello,

Dorico 3 Pro started only playing sound out of the ‘left’ audio channel. I went into the Audio Device Setup in preferences and the only available output is Stereo Output: "1, " - Dorico is not recognising the second channel. I updated to Dorico Pro 3.1.10 this morning and that hasn’t fixed the issue. I have also ‘ran’ the VST3 Audio Engine to no avail…Does anybody know how I can get my 2nd output channel back??

I’m on a 2019 MacBook Pro running MacOS Catalina 10.15.3

Many thanks!

Welcome to the forum, KyleS0410. That’s very odd! Can you try quitting Dorico, then trashing the VSTAudioEngine3 folder from /Users/your-username/Library/Preferences, then start the program again and see if it sorts things out when it rediscovers your audio hardware and plug-ins?

Hi Daniel,
Thank you. I binned both the VSTAudioEngine2 and VSTAudioEngine3 folders from that directory and I still have the same ‘graphic’ in the Devices Set Up menu.


Audio definitely only coming out of the left channel.

All audio works fine from Cubase 10.5 Elements however, so I confess to being highly confused!

Please choose from Dorico’s main menu ‘help > create diagnostics report’. That creates silently a zip file on your desktop. Please attach it here. Thanks

Hello, here is the diagnostics report.

Thank you for the help.
K
Dorico Diagnostics.zip (378 KB)

Thanks. So Dorico “sees” both ports, i.e. left and right, but I suspect the problem is that right has an empty name. See the according log output:
2020-04-29 17:45:00 : enumerateCurrentOutputIds: 2
2020-04-29 17:45:00 : =>1
2020-04-29 17:45:00 : =>

I don’t currently have a Mac at hand. Can you go into Audio MIDI Setup (I think that’s the name of the utility) and change the name of the output ports to something like ‘output 1’ and ‘output 2’. Then start Dorico again and start with a new project.

Hello,

I have opened the Audio MIDI Setup utility but cannot rename or reconfigure the outputs.


I have restarted the computer since checking, but no change here either.

Best,
Kyle

However…Cubase is now also showing the same output issue…


:unamused:

Hm, then it is a problem of the operating system. Could you please follow the instructions from https://steinberg.help/cubase_pro_artist/v9/en/cubase_nuendo/topics/vst_connections/vst_connections_inputs_and_outputs_hardware_renaming_t.html
On the other hand, what if you use your Scarlet audio interface, is then everything fine?

That’s what I figured, but I can’t find how to access the naming properties to give that output channel a name. Which is incredibly frustrating…

Cubase ‘works’ - audio is certainly being sent to both channels, but when I click on ‘Audio Connections’ Outputs, it still has an unnamed [Stereo Out - Right] box.


When in the Audio MIDI Setup utility, the option to ‘configure device’ is greyed out; and I have been unable to find any way in which to access it…as I assume this is where I’ll be able to rename the channel…?

Thank you for your help! Much appreciated.

Yes, Cubase works, but Dorico is choking over the empty name.

Let’s try something different. How about you create an aggregate device?
Here’s an article that describes how to do that: https://support.apple.com/en-us/HT202000
Though it’s called aggregate, it also works if it only contains one device (your built-in audio)
If you create that and then in Dorico in the Device Setup dialog choose as driver the aggregated device,
does it then work?

Also, sorry, Dorico doesn’t want to behave with the Scarlett…still only playing out of the left channel. If I pan the master output hard right I hear nothing at all.

Cubase though is now fine having followed the instructions on the link you sent - although the channel still remains ‘un-numbered’ in the “Studio Setup” menu. Having renamed it in the ‘show as’’ box though, it is appearing correctly here.



Thanks!

Can you please send another diagnostics report?
Also, how about the aggregate device as I wrote in my previous posting?

Sure.

Sorry, the aggregated device shows up correctly and works fine. The built-in option not displaying port 2 appears to be the only problem.

And diagnostics report attached.
Dorico Diagnostics.zip (1 MB)

Good to hear that it works with the aggregate device. That is a perfectly valid workaround that you could permanently use.
But for me it is unsatisfying, because I still don’t know how the system could get into that “funny” state.

What if you choose the built-in audio and start with a new empty project, is that also muted on one channel then?

That’s exactly how I feel about it! I like things to work ‘properly’…deeply unsatisfying!

I’ve tried that and it still acts in the same way - all the other software I’ve got doesn’t even pick up on the name issue; just the Steinberg stuff. It’s odd…but as you say, what is going on is unclear and the folks on Apple chat were not hugely helpful either, so this will do for now!

Thank you very much!

When I have hands on a Mac again, I will do further investigations.

Interesting: I was just dealing with another customer on a completely different problem, but from his logs I saw, that is is also using the built-in audio device. Also there the second output port has no name, but it works just fine with that other user…

Actually, I’ve discussed this with one of our engineers, and it appears that on some newer Mac models sometimes the OSX’s CoreAudio system passes us such funny names. It’s not really clear, how or why that happens and in the end it might still be a bug on our side, but for the moment we believe it to be more on Apple’s side and we continue having it on our radar.

That’s really odd…(sorry for the lack of response…it’s been a hectic week!)

I wonder if it is a operating system issue? I’ve certainly never encountered it elsewhere…! Thank you for your continued support and advice, I’ve been using the ‘aggregate device’ and it all seems to be working absolutely fine!