audio connections > change default device port

yet I somehow managed to make a global change, the first time I opened cubase with my newly installed ur-rt2… a change that I cannot find how to take back!

Can you pease do a screenshot of the audio connections box when you open an old project, before you change anything? Very curious as to what it looks like.

Hi,

I don’t think so. I would expect you did the very 1st settings, which was inherited to the other projects afterwords.

a screenshot of me opening an old project, where you can see that automatically the effect bus is selected…

Martin, when saying “the very 1st settings” what do you mean? What happened was that after installing the ur-rt2 drivers and opening cubase it asked me what bus I wanted to have as a default, and I accidentally selected the effects bus. After that I am trying to find a way to change that (global) selection…

It’s not selected automatically “by accident/luck”. It’s inherited from the previous project you opened before you created this one.

Cubase works this way: If you connect any Audio Device for the very first time, Cubase tries to connect some ports. It tries to somehow follow the connection you had before with other connected device (for example if you were using port 3-4, it tries to use again ports 3-4). Of course, it might happen it doesn’t make sense for the new device, so the user has to adapt it.

Then Cubase follows this user decision.

When you create a new project, again, Cubase tries to guess what you want to do. And the most stable way seems to be just keep the I/O settings of the previous project (or make the “default” setup, you define by the “default” preset).

That’s the logic.

Martin, that’s what I would expect! But in practice it does not happen. I can try changing the setting and save the project. I can try opening a new project and save it with the correct setting. What happens invariably is: new projects open with the correct bus, old projects open with the effects one… (of course after I save them they are ok, but every other old project I open still uses the effect bus, one would say, as a default…)

Hi,

Yes, this behaved as specified. Because the settings is stored in the project, so it’s loaded together with other project data.

Martin, what was stored, in fact, was my last sound card, i.e. ur22. Why an old project would open with ur-rt2? And why with the effects bus? And can I change that, so that it opens with the plain bus (not the effects one)?

Hi,

The Audio Device is not stored. Just to routing to the busses. So it wasn’t stored as UR22 Out1 and UR22 Out2, it was stored as Audio Device Out ID 1, Audio Device Out ID 2. Now, when you connect UR-RT2, the Out ID 1 is linked to the FX-L and Out ID 2 is linked to the FX-R. (These are just examples, the IDs might be different).

Yes, you can change it per project.

but why is it linked to the fx buses and not the regular ones?..

In my eyes, this is a bug. i.e. being able to change something globally once, but not being able to undo the change.

Hi,

Because for the very first time Cubase tried to connect to any bus, which seems to be “somehow” similar to the bus you were using before. For example the same output ID.

It’s not a bug, it works as specified.

yes it asked me before doing that, and I would expect I could undo that selection…

so that’s it? I do something and it’s undo-able, unless I pay for pro???

What if I uninstall and reinstall ur-rt2? Would that do the trick?

Hi,

I don’t think so. But you can try.

mmm… is there somewhere that such preferences are stored? If I found the file maybe deleting it would force cubase to ask again?

Hi,

You could try to delete (or temporarily remove/rename) the whole Cubase preferences folder.

where is this to be found?

Hi,

On Windows: %appData% Steinberg/Cubase 10 fodder. Rename it to get a default factory preferences.