Audio Cutting Out - Solved!

@Janus , It is possible nothing changed. My last major project was created aa an audio mockup in a DAW and the MIDI was imported. I may just be noticing the oroblem because I am using Dorico heavily and using it amd NotePerformer to create the audio.

But you have a problem that must be fixed, regardless.

That page also suggests a reset, as I did too:

@Andro , I don’t know where to find that that audio reset. (Have I mentioned that I hate Windows 11?)

As far as uninstalling/reinstalling Dorico and Windows, I appreciate the suggestion but this is a new machine with a new install of Dorico 5. I don’t feel confident that would help. Thanks, though.

I think I will stop taking everyone’s time here until I follow up with @Ulf .

You are all great but I am using far too much of everyone’s time.

Thank you,

The Audio Reset is in Dorico preferences.

I don’t think this is a Dorico problem. After all, nobody else in the user base has reported it, at least, I have never seen talk on the forum about Surface Dorico dropouts. I really think you should run all the troubleshooters I have mentioned, and do the resets.

I am very happy and keen to help, but allow me to remark that keeping repeating that you hate Windows 11 does not advance anything. One wonders why therefore you bought a Windows computer.

OK. Good luck.

I was joking about Windows 11 because it is hard to find settings. I liked other version of Windows and did not know what Windows 11 was like until I bought this machine. People don’t always like OS upgrades on Windows or iOS. If that is irritating I won’t say it again, but it was not a serious comment. I’m trying to maintain a sense of humor about this situation.

I did this as (see image) @Andro suggested. I think I will hold off a day before marking this as solved, but I did manage to play an entire score without a dropout so that is greatly encouraging. Thanks again for all the patience.

I think I need to host a dinner party for all of y’all.

1 Like

Hey! Wow!

2 Likes

Spoke too soon. Issue still not resolved.
@mducharme , I will look into Latency Mon.
@Andro , Here’s the Windows build:
Windows 11 Home
Version 22H2
OS Build 22621.2134
Windows Feature Experience Pack 1000.22659.1000.0

This post has gotten so long that I can’t find who suggested Resplendence.com. I went there, downloaded the Registrar Registry Manager and installed it. When I run it, it asks if it’s OK to make changes to the computer, I say Yes, and then I get a blank white screen with icons along the top and an address bar. I don’t know what I’m supposed to do with that.

By the way, if you clear the cache and reset the audio engine in the VST section of the Preferences, you have to go back and change the sample rate again. I can’t tell that matters, but I am trying to keep it at 48K because that’s how Windows is set. (I don’t see a 44.1K option in Windows: just 48K 16-bit and 48K 32-bit.)

A fan of Occam’s Razor would say there is a basic set-up parameter we are not thinking of, but I doubt all the smart people here would miss it.

1 Like

Isn’t it LatencyMon you need, not a registry manager?

Yeah, the registry manager is not what he wants, I didn’t even know that company made a registry manager. @konradh Resplendence LatencyMon is indeed what you want. It is essentially the replacement for the old “DPC Latency Checker” used for the same purpose way back on Windows XP that I used to use nearly 20 years ago.

You have to run it for a few minutes and use the system normally while it is running. It will always start by saying “your system appears to be suitable for handling real-time audio”. It will need some time to see if there actually is a problem. If there is one it will change to a warning. If it finds a problem, then the issue is with a very low level system service or with the hardware or BIOS - a device driver issue, or hardware fault, BIOS setting, power management, or possibly very low level applications like anti-virus software (which integrates closely with the Windows kernel). If the latency checker finds nothing wrong, then the issue is not with the low level hardware or system services, and is instead either a user mode software issue or a performance issue. Either way, it will narrow things down for you substantially.

1 Like

The problem with LatencyMon is that it gives really lowlevel CPU stats and no hint as to what to do about anything. Even though I have 40 years software development experience I have nil idea what it is telling me. Worse, it says - even after running for a long time - that my grunty Windows machine is no good for real time audio, even though it is, and I never experience dropouts or clicks.

Solved! I unchecked the box as shown in the image and have played a score repeatedly today with no issues. I feel 99% confident that this is resolved.

I don’t know how to thank all you wonderful people for working so hard to help me. I hope I have an opportunity to repay this kindness.

10 Likes

I’m gald to hear that your issue is solved.
Though, the solution surprises me, because you said that you did not change anything, but by default that option (WinRT MIDI) is switched off and there is no mechanism in Dorico that would automatically flip the value. So from my perspective, you must have changed at some stage that option yourself.

1 Like

Very good.

You see, it was a Bluetooth related issue, even though you are not using a Bluetooth device. So at least one of my suggestions was correct!

My advice is that Bluetooth causes a lot of problems in pro audio and is best avoided. Never use Bluetooth headphones for studio work. That’s why all the pro headphones come with a cable and a plug.

1 Like

I agree with Andro, but there are more and more MIDI controllers coming out that use MIDI over BlueTooth and you can’t really blame people for wanting to use it, that’s why we have that option.

1 Like

Just to finish this out:
1-When I first bought this PC, I bought a backpack-sized Korg Bluetooth keyboard for use away from home. It never worked either by Bluetooth or USB and I returned it to Sweetwater Sound–thus my comment that I was not using any Bluetooth devices. Sweetwater uses remote sessions for troubleshooting, and it’s possible that option was checked in the process of trying to make the keyboard work. I was not aware of that and it is hidden away under Advanced options. I found it by going through and testing every Dorico option one by one, even if it did not seem to apply. (Our initial focus was on Windows issues and audio set up.)
2-My first major Dorico project was fixing MIDI I imported from my DAW. Most likely the drop-out issue was always there but not noticeable until I started scoring heavily from scratch.

Like all riddles, the answer is obvious once revealed.

Thanks again.

2 Likes

You are welcome :smiley:
And was it a Korg MicroKey Air? I have one of those and it is terrible. I once got it to work via BT , but reconnecting it I got failure after failure. It’s far from an easy plug’n play device.

1 Like

Yes! I hated it and it was frustrating–plus look at all the trouble it caused. I had an old Akai LPK-25 lying around the studio, and once I got the right USB adaptor, it worked fine. I don’t use it for entry often, but it’s great for testing out phrases.

Sweetwater was great about giving me a refund for the Korg.

Same here, I also have an Akai LPK 25 :smiley:

1 Like

Just to chime in here.
I just started to experience the exact same symptoms, and sure enough, that WinRT Bluetooth setting in advanced settings was checked.
Here’s the thing. I have never been anywhere near those settings and I am absolutely certain that I did not change that, so I’m at a loss as to how it ended up enabled.
Sure enough, unchecking the box and restarting completely cure the playback dropouts.

Thanks all!

Tim

1 Like