Audio dropouts again, ur22mkii, maybe usb? --- SOLVED

Hi all,

Yet another ‘audio dropouts’ issue with the ur22mkii. Thought I’d chronicle my journey here, hoping to get help, at least notes might help others.

Backstory: I had Win10 on a 2015 Dell Inspiron 15R with this ur22mkii (I use Cubase LE4) and it worked flawlessly for years. THen spilled wine on my laptop and it died. Bought a new Acer Aspire a515-52-7290 and installed all software and now experiencing dropouts (first time for me). I have 10 days before I return it to Best Buy to get my money back, so hoping to gain some confidence here that this will somehow work!

Day 1 issue, first search led to me Steinberg’s post about mmcss threads.

Tried:

  • Firmware & driver up-to-date (1.10.4 and 1.04).
  • Latency mon shows all green bars (and says good latency)
  • Cubase Processor affinity (6 logical cores only)
  • Acer locked down BIOS, cannot disable HT or Turbo Boost
  • 32 threads mmcs prio / 96 failed from mmcs test script
  • audioengine.properties

IF processory affinity works then in theory shouldn’t that fix the issue they reported? I can’t limit logical cores in BIOS cause no option (boo Acer).

Also, to be clear, this is definitely not a Cubase issue per se, as I get the dropouts even when playing any audio through the unit (i.e. youtube -> Chrome -> ur22mkii -> headphones). CPU is NEVER over 10%. And don’t suspect ASIO - the meter in Cubase is always at the bottom, so no latency. I also tried changing buffer sizes when using Cubase, but no success (side question - is there a way to modify buffer sizes in the ur22mkii driver directly? The latest driver I installed 1.10.4 either doesn’t have GUI config page or failed during install?)


Day 1) Power management (system sleep never, screen off never, usb power suspend disable, disk & cpu same), disable firewall, exit OneDrive, reboot, problem still there, exit OneDrive again after reboot, problem still there, start reading more online for 5 minutes, then problem goes away all of a sudden and I get 2 hours of solid performance.

Day 2) Next day, problem back. Windows explorer options, C: drive, uncheck ‘allow indexing’. As soon as I click apply Windows starts undoing indices and 100% perfect performance WHILE the operation is ongoing. As soon as it was done, terrible performance. Then did the same for D: drive and identical result (perfect performance while operation ongoing).

Day 3 is today) Noticed today that USB light on unit would go off/on, mostly coinciding with the dropout. Uninstalled firewall, tried DC power to the unit, moved from usb 3 to usb2 port, disabled Intel Link Power Management, rebooted, after reboot (still plugged into usb2 slot), seemed to work better.

So…is usb control issue? Something with disk?

A flashing light on the UR (at least on my UR44) means the unit has power but the driver is not loaded yet (i.e. on boot up) or is “not yet communicating with the OS.” So, if the light is going out or flashing, then MAYBE there is interruption in the driver. One thing that might cause this is the USB port being put to sleep to save power. In the power profile, disable any USB suspending features. Also, the computer going to “sleep” instead of actually shutting down seems to cause the drivers to not re-load properly sometimes. I never let the PC sleep. Hope it helps.

Thanks jaslan. Already disabled USB selective suspend and put the computer to sleep Never. 99% sure that I did that yesterday so I don’t think it went to sleep last night, but I’ll check again tomorrow and report.

As for today, now that I have the unit plugged into usb2 port instead of usb3, I’ve just been using it for 2 hrs with no issue. Fingers crossed that it’ll hold.

Err… correction: not 100% it’s a USB 2 port, but it’s a different USB port (on the right side of the laptop instead of left). I assumed it was 2, but looking in Device Manager I see it’s actually listed under ‘USB Root Hub (USB 3.0)’. Either way, this port seems to be working better than the other side.

Audio dropouts is all that happening? Maybe also some annoying crackles, pops, distortions just like my UR22 on the video? https://youtu.be/CipRMXYu8UA?t=204

Also, since you didn’t mention it specifically, you do have the latest drivers and firmware? You mentioned everything worked fine for years so I thought you may never have updated them. There were some Windows updates that triggered some changes to the drivers.

@Aileo: No crackles or distortions, though I used to have them terribly with an e-mu 0404. I understand that to happen when the ASIO is overloaded. Are you watching your ASIO meters? You might try ASIO4all as an alternative?

@jaslan: yes 1.10.4 and 1.04.

So far, still so good with the other USB port though. 5 hours good performance. I’ll wait a few days before calling it done but I like the spot I’m in!

Alright, I’m putting this to bed. It’s been working great on the other USB port, so I guess for now everything is ok. Thanks very much for your help @jaslan.

It is one of those weird things… Sometimes, maybe USB ports on opposite sides of the laptop (or even the same side) can be controlled by a different controller cards and maybe compete with a hard drive or network controller or some other device and the audio gets interrupted. I don’t really know…
Glad its working for you.