Audio dropouts in Cubase 12.0.20

Activating Audio Power Scheme seems to have helped a lot

That’s perfectly normal and is not related to Cubase.
When you play the same chord repeatedly, the number of voices that are played simultaneously rapidly increases and overloads the realtime processing.
To prevent this, most VST instruments have the ability to set a maximum polyphony limit.
I don’t know about Roland but that’s usually the setting to you should find and tweak first when your CPU isn’t fast enough. (Or the synth is too demanding, you get the idea)

Activating the Steinberg Audio Power Scheme is basically the same thing as the Windows High Performance power plan, apart from a few minor things.
That will simply put your CPU to its maximum clock independently of the load.

But, it all depends on your actual CPU settings. The best is to leave the Power Plan on Balanced in Windows, and do the right setting in the BIOS.
The good thing is that we have the same CPU and Chipset.
I don’t know if the settings are labelled the same nor where they are located on an Asus motherboard (because I have an MSI), but here’s my settings :
What’s in bold was disabled or set to a different value by default.

  • Clock/Ratio settings = Auto
  • Intel Turbo Boost = Enabled
  • Enhanced Turbo = Enabled
  • EIST = Enabled
  • Intel Speed Shift = Enabled
  • Intel C-State = Disabled
  • CPU Core Voltage Mode = Auto
  • CPU Core Voltage = If you leave it on Auto it is too high. It is better to set a value manually. For me 1.250 V is working good. (for information, Auto is 1.38 V under load)
1 Like

What makes you say that? I have never seen anyone recommend a Balanced power plan in any version of Windows. I would highly recommend against it! Why would you want the OS to arbitrarily put components in a low power state?

Because he is disabling the c-states of the CPU in the BIOS, which basically prevent the CPU from going into power saving mode.

The disadvantage is that your CPU is running full power all the time. If you use the PC exclusively for DAW work, that might be fine, but if it is a multi purpose system, not unusual with hobbyists like me, it is not what I would want (I have a dedicated power plan which I activate via a batch file for DAW work).

Windows power plan governs more that just the CPU power. I still highly recommend against it.

I know that the High Performance power plan does not only affect the CPU frequency, but also SSD/NVMe power management and many other things that can increase the performance.

Would you agree to make a test ?

With the defaulted power plans :
Set the power plan on Balanced and set the Minimum Processor State to 100% so the CPU clock is always at its maximum.
Open whatever project in Cubase or run any benchmark program.
Now set the power plan on High Performance, and compare Cubase performance or benchmark scores.
Do you see any noticeable difference between the two power plans ?
If you do, then I’m really impressed.

If we follow the same logic, the Ultimate Performance power plan is supposed to give even better performances than the High Performance one. But no one would actually see the difference in a real world setup.




No, disabling C-States doesn’t make the CPU run at full power all the time.
It only disables the CPU power saving features.

Basically, C-States are only really useful when the computer goes into sleep, when the screen turns off, or when you let the computer idle and there is almost no load.

Of course C-States also work when you actually use the computer under certain types of load, but then this is more of a passive thing to help save power even more.
The C-States won’t be as deep as in the situations above.
A core can enter and exit soft C-States many times per second, but doing so will cause the core to be unavailable for the time it takes to “wake up” when it gets told to work. This feature indeed steals some CPU cycles and can lead to lower performance.

Since Cubase usually has a relatively low CPU usage (I mean even with a 50 tracks project, the load is very far from a constant 100% usage like 3D renders), disabling C-States can for sure help, but the improvement will be very slight, if not absent in most cases.

Disabling C-States isn’t a magical performance solver.




The ability for the CPU clock to change is not related to the C-States, but to EIST (Enhanced Intel SpeedStep Technology) and the more recent Speed Shift.
For the CPU frequency to be able to move, either of EIST or Speed Shift may be enabled.

For the best reactiveness concerning the speed at which the CPU clock can change, I highly recommend to enable both EIST and Speed Shift.
Speed Shift is the most important setting you can actually enable. The CPU Clock will react extremely fast to any load, and will not cause any performance issue.

Speed Shift is extremely well implemented into Cubase, if not the best implementation in any software I’ve used, so there is absolutely no reason not to allow dynamic clock with Cubase.




It is possible to get the CPU to react to the load, even with the High Performance power plan.

The adaptive clock in relation to the load is governed by a hidden Power Plan setting called “Processor energy performance preference policy”, and the usual Min/Max Processor State settings, which simply set the clock limits.

This hidden setting is the Speed Shift fine-tune, and acts like a soft knee threshold where the CPU clock can change depending on the load.
When High Performance power plan is selected, this setting is set to 0 by default, and that is why the CPU will work at max speed, even when there is no load.
To make it visible in Power Plan settings, you must go into the registry, search for this entry and change the Attributes value to 2 :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\36687f9e-e3a5-4dbf-b1dc-15eb381c6863

Now it is visible, you can go into your High Performance power plan settings, and change the value to somewhere between 30 and 40.
It depends on the number of background tasks you have during idle, so experiment accordingly, and use a monitoring graph when you do so, for example Afterburner/RTSS.

However, don’t forget to set the Minimum Processor State to 0%, don’t keep it at 100% or the clock won’t be able to move.

With only the default background programs running, and without touching your mouse (idle), you should aim for a flat line on minimum CPU clock.
It may do some spikes but that’s not a problem, you even should allow it to make some spikes from time to time during idle, for example when Windows fetches updates and does its things, and most importantly when you move the cursor over the desktop.
The latter would confirm that the system will be as responsive as possible to any load, and at the same time reducing power consumption when there isn’t.

2 Likes

Thanks for the detailed information! I am definitely not a hardware guy, and it shows :wink: i did actually write a specific cpu stress test program once for testing our servers, but those had pre-defined workload profiles which set a shitload of values I have no idea about… the results were interesting. Your regular cpu stress test apps are rather useless, because they usually just max out all cpu which is not real world, so my program simulated some intermittent pauses between calculations. Then there were measurable differences between different CPU BIOS settings.
Sorry, OT…

1 Like

Yes, I agree that when the workload is highly fragmented, the different settings can exhibit noticeable differences.

I need some advice based on this discussion.

My new Dell XPS 15 runs Windows 11 and there is NO option for the High-Performance Power Plan. I have done some research, and it seems that it is not possible to restore this plan any longer. My only option is to use the Balanced Power Plan - therefore, I need to know which BIOS and Cubase settings I can use to get around the lack of High Performance and simulate High Performance.

As it stands, Cubase 11 is unusable because of audio dropouts.

Hi, did you try to restore it by using the CMD ?
You need to run CMD as an Administrator or this may not work.
Then copy the following command and execute it :

powercfg -duplicatescheme 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c

It should work.

Keep it mind that Laptops have specific power management settings and are shipped with custom Power Plans, and in most cases the user should not modify it.
If the above doesn’t work, then you can try disabling CsEnabled in the Registry.
This will restore the default Power Plans. but they won’t be optimized for a laptop anymore.
Do that at your own risk.

How to do it :

Open the Registry Editor and search for :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power

There should be a CsEnabled entry on the right panel.
Double-click it, and change the Value data to 0.

Apparently some computers do not have the CsEnabled setting, and have restricted power plan settings.
If available, you can set the Minimum Processor State to 100% so the CPU will run at max speed, but doing so will not fix everything. Laptops have much more hidden settings under the hood that may affect performance.
Also in Windows 10 or 11, you normally have a slider that can be used to set the computer from energy saving to performance. It is normally located in the setting menu, bottom-right of the desktop.
One very last tweak would be to do what I’ve share in my long post above :

This new setting should be available in Power Plans, and set it to 0.
The CPU should run at max speed.

I was wondering, did you have similar issues with C11?

I have already tried using that command in the CMD window to restore the default power plan but it didn’t work. In fact, there is no CsEnabled entry in the registry at all. They seem to have removed.it.
I have changed the battery setting to performance but that doesn’t seem to change anything since the power plan is still Balanced.

Well you can still try the tweak I shared just above.
Just, is the laptop plugged in or running on battery ? I need to know just in case.
Also, what buffer size are you using, and how big are the projects, and more importantly, what’s the exact model of your PC ?

Buffer size is 128. Laptop is always plugged in but it’s not a dedicated laptop just for audio - I use it for day to day stuff and general use. It’s a Dell XPS 15 running Windows 11, with 16GB RAM and 1 TB of SSD storage. Intel 7 processor I think.

Projects are pretty modest as I’m just a hobby artist. I usually have somewhere between 15-40 tracks and I try to keep the number of plugins under control.

I will try that tweak later and let you know. Ill also give a list of options I can change in the BIOS as I don’t know which ones to enable or disable.

Oh, I think the buffer is too low, you should only use low buffers for recording live, but when your project grows bigger, you should always increase it.
Just try increasing the buffer first. :wink:

Performance should not be an issue at all with an i7.

I have posted some of my BIOS settings in a previous post, here they are !
Note that some may not be available on your PC, or can be named slightly differently.

What buffer setting would you recommend?

Latest update on my system changes (still on Balanced Power Plan as that is all that is available)

  • Clock/Ratio settings = ?? couldn’t find this
  • Intel Turbo Boost = Enabled ✓
  • Enhanced Turbo (maybe Intel Boost Maximum Technology on mine) = Enabled ✓
  • EIST = couldn’t find this
  • Intel Speed Shift = Enabled ✓
  • Intel C-State = Disabled ✓
  • Intel Speed Step = Disabled
  • Intel Hyper-Threading = Disabled

There was also something called Thermal Management which was set to ‘Optimized’ - there was an Ultra Performance option where processor and cooling fan speed are increased for more performance. If the issue still persists, I will try this. There is a warning saying there will be higher temperatures and cooling fan noise.

I tried your trick with the Registry but changing the Attributes value to 2 did not make any difference. There is still no High Performance Power Plan in which to adjust anything.

I set the buffer size to 512. I will monitor the audio drop outs.

I use the Audio Performance dialogue box and it’s basically close to processing overload or actually overloading quite often.
Screenshot 2022-07-16 162947

Still getting audio dropouts.

At this point, my plan is to try to clean up the projects by rendering midi stuff, removing unused media or tracks and reducing the number of plugins on the tracks. The last resort is the Ultra Performance Thermal Management option, although it sounds a but scary - I have visions of melting motherboard chips and cooling fans blaring noisily the moment I open any app at all.

Was hyperthreading disabled by default ? You need to enable it.
Set the buffer to the maximum and start from there.

This tweak isn’t about the high performance power plan… I’ve never stated such a thing, it is about a making a hidden setting visible in the power plans settings (in all power plans).

The Steinberg help center advises to disable Hyperthreading for best performance: https://helpcenter.steinberg.de/hc/en-us/articles/360008589880-Windows-How-to-set-up-and-optimize-a-Digital-Audio-Workstation
“Disable Hyper-Threading (Intel)/Simultaneous Multi-Threading (AMD) in the UEFI BIOS if your CPU supports it and if your BIOS allows you to modify this setting.”

I guess I misunderstood your tweak in that case.

The “Disable Hyper-Threading (Intel)/Simultaneous Multi-Threading (AMD)" obviously refers to the previous sentence :

Modern systems with a fully updated Windows should not need any of the default settings to be modified. However, if certain drivers are not fully optimized and you experience audio drop-outs, it is worth having a closer look.

Your computer isn’t an old relic from the late 2000’s, it is really good, so you shouldn’t have hardware related performance issues.
You are experiencing audio dropouts even without Hyper-Threading, so the issue comes from somewhere else. Disabling it can actually lower the performance… so it is best to keep it enabled.