Audio Engine Process Died crash log

Here you go. I hope you can now help me launch Dorico! (16.3 KB)

I’ve logged this internally (ref: AD-246). Our audio engine specialists are currently away, but they’ll be able to take a look when they return. I’m not sure what to suggest in the meantime if the usual cleanup script isn’t helping. As far as I can tell, the engine seems to be crashing during the plugin scanning procedure. Normally the engine log would tell us more, but is it still the case that you’re not getting a log file?

To get to the log files you need to go the terminal and type

open $TMPDIR

which should open a Finder window, then look for a VSTAudioEngine folder. It should contain some log*.txt files.

Have you tried reinstalling, in case something has got corrupted?

Cleanup didn’t work. log files are still empty. I’ll reinstall now.

Yikes! Reinstall failed 4 times in a row. NOW I’m getting frustrated.

Does the installer give you any information on the errors? Unfortunately I don’t know much about the mac installer.

Normally the Mac installer fails only if something else is trying to access the eLicenser. So first try quitting all other Steinberg apps and anything else that might be using the eLicenser, like Vienna if you have it, and then try running the installer again.

I’m really sorry you’re having these problems and hope we’ll be able to get you back up and running very soon.

Can you attach the installer log when it fails? See

Yep, Vienna was running. I’ve reinstalled Dorico and it’s still dying at launch. Sigh.

I’ve just had a quick glance at your crash report, and from the callstack it looks pretty much like it is the usual ObjectiveC Runtime Library issue we had with many plug-ins.
For the background, during startup the audio engine loads and unloads every plug-in that it can find, to check what is currently available. The problem then is, that upon unloading of certain plug-ins the ObjectiveC Runtime Library gets into a funny state and then the engine crashes. The same issue we also have with Cubase. The bug is actually on Apple’s side, but Apple is slow to react, and so our advice to other 3rd party plug-in vendors is, to recompile their plug-ins with different compiler settings as a workaround to Apple’s bug. Well, we can only recommend that to other vendors, but if they really follow our advice…it’s up to them. The other problem is, bring such an update to all end users. Because how do they get to know that they still have an old versions that may cause trouble in Dorico or Cubase?

Okay, so far I’ve just explained why and what happens, but not how you get around the crashing issue. So here we go: You need to find out which of your plug-ins is causing the trouble. Easy, he? But seriously, please move your 3rd party plug-ins one by one out of the way. So first you move an arbitrary plug-in out of the way and start Dorico again. If it still crashes, move the next out of the way and try starting again. Then you iterate over and over again, until it doesn’t crash anymore. Then you know, that the last plug-in you moved out of the way is the culprit and you can move all others back into place again.
When I say ‘move the plug-in out of the way’ I really mean that, and not uninstalling or deleting. So on Mac the plug-ins are usually at some place in /Library/Application Support. I’m more of a Windows guy and don’t know the exact locations on Mac. I’m not in the office at the moment, and so can’t look them up on my MacMini. Maybe someone else here reading this can step in. So move the plug-in files onto your desktop or into a new folder in your documents, somewhere where you can easily find them again.

Thanks for looking at my crash report. I have MANY plug-in on this machine and I don’t look forward to the process! Cubase launches with no problems, for what it’s worth, with the exception of twice yesterday.

Sure, I understand it is tedious if you have so many plug-ins. In that case, could you please start out with a different, much simpler test: Rename temporarily the ‘VST3’ folder and then start Dorico again. If it’s not crashing, then you know it’s one of the items in there that causes the problem. If it is still crashing, then we have to look somewhere else.

I’ll do that

Well, bad news, I guess. Renamed all of the VST folders and still crashing on startup. Any more ideas?

Okay, then it is not the VST plug-ins, but there are also other plug-ins that the audio engine can load, and these plug-ins may also be affected by that ObjectiveC issue.
Could you please have a look under /Library/Application Support , somewhere under that branch there is a folder Steinberg/Components. I don’t have a Mac here at the moment, so I can’t properly look it up. But if you find that Components folder, please temporarily rename that and try starting Dorico again. Does it work then?

Yes!!! That worked! Now to find the culprit plugin…

Found the problem- it was vst.connectpro.bundle. I had done the thirty day trial a while back and it was still lurking about in the components folder. Thanks so much for your help! I can now get started with posting complaints about all the things that are missing from Dorico. :slight_smile:

Excellent, I’m so glad you found the culprit and can work now with Dorico.
We knew that there is an issue with very early versions of VstConnectPro, but didn’t expect it to be still around with some customers. If you want and need VstConnectPro in your daily work, you can download the latest version of it from the Steinberg website. That one won’t crash anymore in conjunction with Dorico.

I have also had success with running Dorico, finally, on my second computer, after I downloaded and installed the latest VST Connect Pro, followed by: starting Wavelab 8.5 (trial mode) and later starting Cubase 8.5 pro (full license) sessions with VST Connect (SE version, maybe the Pro version) plugin and changed some settings in a VST Connect session on and off.

I have a similar problem which remains unsolved (I’ve tried installing VST Connect Pro). Dorico crashes at startup (the VST Audio Engine) and then the start up logo says, in the lower left corner, “Audio engine process died” indefinetly. I’m on Windows 7, so I know my OS isn’t supported - but it should work nevertheless. Cubase 8.5 works perfectly. I use a Benchmark DAC2 as audio card.

Here is a crashdump file and the application.log.