Audio Engine startup difficulties

Since 1.1 my startups have been about 90% very slow. I’ve tried what Ulf recommended in another thread about Audio Engine timeouts (deleting the VSTAudioEngine preference folder), and it seemed to have fixed the problem, but only for a couple of startups.
When I look in my Activity Monitor (mac) I see that VSTAudioEngine is not responding and that a number of vstscanner and vstscannermaster processes are running.
Sometimes Dorico opens without a problem, but most times it either ends in ‘Audio Engine Timeout’ or the program freezes at ‘Finish Scanning VST3 Plugins’.

Any ideas?

Could you please zip up the folder /Users//Library/Preferences/VSTAudioEngine and post here. The log files will help us identifying the problem.

Sure thing!
VSTAudioEngine.zip (249 KB)

Thanks for the data. The logs says the last run of the audio engine was yesterday, June 29th around 6pm, is that right. It was loading three instances of HALion Sonic SE when the log suddenly breaks off, so I guess that’s where the audio engine went ‘not responding’.
What is also weird, you say that vstscanner processes are running all the time. Well, they should go away after a few seconds or minutes when finished scanning.
May I ask you to run the clean up script as found in the thread https://www.steinberg.net/forums/viewtopic.php?f=246&t=104450 under the section “Dorico or the audio engine is behaving strangely. How do I reset things?”
Check again in Activity Monitor that the audio engine and scanners are gone. Then restart Dorico and just create a very simple piano project with a handful of arbitrary notes. Then choose Help > Create Diagnostic Report, that will create a zip file on your desktop. Please post here.

When I try to run that shell script I get an error: ‘/bin/bash^M: bad interpreter: No such file or directory’
A cursory check on stackexchange suggested I remove the ‘^M’ from the ‘#!’ line at the top of the script, but that line reads only ‘#!/bin/bash’, so I have no idea why I’m getting the error.

Let’s forget about that script then for a moment. Go to Activity Monitor and make sure that the processes Dorico, VSTAudioEngine and all vstscanners are not running.
Delete the whole folder /Users//Library/Preferences/VSTAudioEngine . It will get recreated and filled up with the next start again.
Then start Dorico anew. The audio engine will invoke the vstscanners to scan all your available plug-ins again. You have quite a few, but still, it shouldn’t take that long, let’s say not more than half a minute.
Does it start up normally or again with a timeout of the audio engine?
If it starts up, please create that mentioned piano project and do Help > Create Diagnostic Report.

I had previously fixed this by killing all the VSTAudioEngine and vstscanner processes, deleting the VSTAudioEngine folder and starting new, which caused a dialogue to come up asking for the location of my Waves plugins (which I no longer use). I would click Cancel and Dorico would open fine that time.
After quitting I would have to redo this whole process (and notably each time I quit the VSTAudioEngine process would quit, but the vstscanner and vstscannermaster processes would remain, and new ones would be created each time I tried to open Dorico).

Anyway, since I don’t use the Waves plugins anymore, I deleted them from both my system and user Library>Audio>Plugins folders (both VST and VST3).
Dorico seems to be opening fine now.

I’m glad to hear it’s working again.

Waves plugins do cause a number of headaches because of the dialogs that they throw up on startup.

Yeah. The weird thing is that the dialog only came up the first time I opened Dorico after deleting the VSTAudioDriver folder.

That’s most likely because (I think) of the vstscanner which tries to instantiate the plugins the first time it runs so that it can blacklist any that appear to crash. It won’t do on subsequent runs.

Interesting. That suggests to me that the issue here is that (at least in my case) the vstscanner WAS trying to on subsequent runs. Every time I tried to open Dorico a new instance of both vstscanner and vstsannermaster processes would appear in Activity Monitor