Audio Engine Timeout

This is new as of today for me: Dorico cannot startup and displays an Audio Engine Timeout message. There’s nothing I can see happening in the background. I’ve tried restarting the computer, but to no avail.

Can you please explain in more detail? What exactly is happening? The startup screen is coming and then nothing anymore? When will the timeout message appear?

Also, could you please zip up the Dorico and VSTAudioEngine log files and post here?

Startup screen displays “Audio engine: waiting for connection” and then “Audio engine timeout”. Never progresses beyond that.

Can you tell me where to find the log files?

On Win:

On Mac:
/Users//Library/Application Support/Steinberg/Dorico/application.log


Thanks for the info. There’s no Dorico folder in the location you specified. I found one at library/application support/steinberg/dorico. I’m attaching that log and the VST log here.

Might also be useful to know that my computer is not going to sleep, as if Dorico were running and the audio engine is preventing it from sleeping.

Thanks for taking a look. (2.62 KB)

Uh, sorry, you are right. At time of writing I did not have a Mac at hands. Now corrected in the above posting…

But for the real matter: Looking at the logs, the audio engine seems to start up normally, begins scanning the plug-ins and then suddenly comes to halt. As to why that is, I can not tell.
I’d like one more info. If you run /Applications/Utilities/Activity Monitor , does in the list of processes still appear the item “VST Audio Engine”? I presume so because, as you say, your computer does not go to sleep. That is usually because the audio engine is preventing it from doing so. If the engine process is still alive, it means it is deadlocked somehow, but not crashed.
I still wonder how that would happen, because so far we never had reports like that.

Please also try the following: First make sure via Activity Monitor that the Dorico process and VST Audio Engine process are not running anymore. Then delete the complete folder at /Users//Library/Preferences/VSTAudioEngine and start Dorico again. The audio engine will recreate that folder and fill up with new files.

If you still have the same problem, then please zip up that whole VSTAudioEngine folder and post here.

Thanks, Ulf! Trashing the folder did the trick. For the record, I had several instances of VSTAudioEngine running in Activity Monitor. Not sure if that’s normal. Things seem back to normal now.

Good to hear that you are up and running again.

And no, it’s not normal having several instances of the audio engine running. That should never happen; I wonder how you actually get into that state. Maybe that is something that you should have a look at from time to time.

I may have spoken too soon… While Dorico starts up, and I can open one of my projects, no other project wants to load. It gets stuck at the 50% progress bar. If I eventually cancel it, the program hangs, needs to be force-quit, and when I restart it, it gets back to the Audio Engine Timeout. Not sure how any of these are related. I’ve tried several projects and there’s only one that opens consistently. All the others hang the program.

Uh, that’s too bad.

And even if you trash the VSTAudioEngine folder again, the other projects won’t load?
Can you provide me one of those ‘faulty’ projects? If you don’t want to post it here publicly, you can send it directly to u dot stoermer at steinberg dot de .

Yeah, they won’t load no matter what I try. I’m attaching one here. Thanks. (330 KB)

Funny enough, that project does load fine with me without a problem on both, my Mac and Win PC.
Also, at a first quick look, the audio engine data in the project file seem to be normal.
I can have tomorrow a closer look, but I suspect that I will not find anything.

What I want to propose to you is, try to reinstall Dorico and see if that helps.


I hate to say this is still not working. I ran the installer again, started Dorico, and I can still only open one project. Every other project hangs and causes Dorico to hang. I have to force quit it (and the VSTAudioEngine process) in order to restart. I started a new project, saved it, closed it, and tried to open it again - same problem. Very odd. I’m attaching the one project that does work (Ligeti) here, as well as the new project that doesn’t. Maybe something will make sense to you?

Thanks (510 KB) (325 KB)

Thanks for posting. I took a deeper look but really can’t see something that is obviously wrong.

One big difference though is, that with the Ligetti piece you are using the Pianoteq instrument, whereas in the Test and Messian projects HALion Sonic SE is used. Now, could it be that something is screwed in the HALion installation and not in Dorico itself?
Do you have other instrument plug-ins? Could you try and investigate along that line? Create other projects that don’t use HALion and try to reopen them.

Also, I’ve created two test projects on my Mac, one using HALion and the other Kontakt. What does happen if you load them? (343 KB)

FWIW, I have no problems with any of these files on W7…

I don’t know if this is relevant, but I can’t get the Ligeti etudes to play sound, even if I switch playback to HALion.

Go to Play Mode and choose Play > Apply Default Playback Template.

In the Ligeti, PianoTeq was listed for each voice on the left, but PianoTeq was not listed under VST instruments on the right (the “rack” was empty) I had to select it manually… it then played back.

No dice… I can’t open your projects, Ulf. I’ve also created a Pianoteq project and a Kontakt project for myself, and I can’t open them, even after trashing the VSTAudioEngine folder. I can also see in the Activity Monitor that the VSTAudioEngine becomes unresponsive sometimes (but not always) while Dorico is hanging on opening the files. Pretty disheartening…