Audio export issue - Solved


when I export Audio, I get some cutouts.

Here is an exemple :

I have no problem with playback.

How can I get a correct audio export ?

Thanks for your help

Is the problem reproducible in all projects? Have you tried increasing the buffer size in Edit > Device Setup?

I have done different tests :

  • use of different buffer size, with the maximum (1024) → still have the problem at a different locations in the file.
    The lower is the buffer size the more I get cutsoffs.
  • test with another file → same problem
  • As I use VSL with VEPro in this 2 works. I’ve tried to switch to noteperformer → same problem

My sound card is a focusrite scarlett solo. I never had this problem before, nothing as changed recently in my setup.

I don’t know enough about the internals of the audio engine to be able to interpret this information correctly, but I’m sure @Ulf will have an idea or two for you to try. The fact that the cut-outs are worse when you have a lower buffer size is undoubtedly significant, but I’m not sure what to do if the highest buffer size doesn’t resolve the issue.

Hi @FlorentG , that is very unusual, because during audio export the audio engine is not under the constraint of delivering a constant data stream within given intervals.
Are you on Mac or Win? And have you tried switching to a different driver before an export?

I’m on windows 11.

I’ve tried to use the generic low latency driver → same problem (test with different buffer sizes)

And you have the latest Dorico? 4.3.11?
And playback is also fine with the Generic Low Latency driver?

I have just complete this test :

  • audio template → reset to noteperformer
  • Generic low latency Driver

I have a complete playback without cutoffs

When I export I get this with multiple cutoffs :

Can you please tick the option about exlusive control at the top of the Control Panel and do an export again. That did work for some other person in the past.

Same problem with this option

Very strange…
Can you please do Help > Create Diagnostics Report and post the corresponding zip file here? Thanks

After many tests, I’ve found the cause of this issue.

I have a Synology Drive. This problem only happens when I export to a folder managed by Synology Drive.

This is definitively not a Dorico issue.

Thanks Daniel and Ulf for your help.

1 Like