Audio export not working

I’m having two problems with the audio export feature.

  1. I can only export once per Dorico session. After that it exports a track having the correct length but no sound. If I restart Dorico, then it will export, but only that one time. So I have to restart every time.

  2. The export begins at the current playback position without saying so. This is annoying in any case, but especially if the beginning of the audio is secretly truncated.

The feature is also missing a progress indicator, so I have no idea when the file might become available, or whether/when my input to Dorico will interfere with the export.

I can’t reproduce either of the problems you describe in the current development build (though I am on Mac and on a supported operating system, rather than on Windows on an unsupported one), so hopefully these problems will be resolved for you in the first post-release update.

It is true that audio export presently produces no progress dialog, and hopefully this is something we will be able to address soon as well.

I am also experiencing the same problem on a Mac. In my case, I cant export anything per session. I tried exporting WAV and MP3, it exports the correct length of the track with ought any sound.

Actually true, we do have an issue with export. I’ve just tried myself with the release build on Win10, same here as well.
At first the file looks empty as nothing is sounding, but occasionally, here and there, you might find that some sounds make it into the file. But of course, basically it is totally broken.

I’ve filed this in our tracking system, so we’ll work on this.

Whatever issue there is (and I’m not saying that there is no issue) it is apparently governed by some factor(s) that vary from system to system. We have been unable to reproduce this in London at all, while Ulf has been able to reproduce it in Hamburg. This will require some more investigation.

Incidentally, gabo00, you might want to try running the default maintenance task in eLicenser Control Center, as that has been known to fix problems with MP3 export (because MP3 export has its own little sub-license and if that license is not set up properly, you won’t be able to export MP3 files).

I’ve found the following: If you load a project and do an export, it will work, but before doing another export, you have to push once the Play button. If you don’t then you’ll end up with the silent file.
If you press Play after an export, the time/bar display will jump to some strange big number, but disregard this, simply press the Rewind button to correct this. But mind you, just pressing the Rewind button will only heal the time display, but not the start position of the next export. So you always have to press the Play button, otherwise the next export will be silent.
So you see, this whole area is buggy and what I’ve described is just a workaround for you, sure we will fix this all up.

What I still can’t reliably reproduce is that what byronhawkins describes, that the export only starts at the current playback position. It only happens rarely to me, but sometimes I find that in an exported file after long silence suddenly sound does come out, but can’t find any recipe for reproducing.
At Byronhawkins (and others), can you always reproduce this? Could you maybe make a simple Piano project with just a few bars and post here the project along with the exported file?

Btw, I’ve found another issue in that exported files always miss the very first note.

There is also a problem exporting a piece with a pickup bar. It seems to omit the pickup, instead starting on the first whole bar. I may have messed up the pickup bar though–it took me several tries to figure out how to get the right number of beats. But the bar looks entirely normal now, and I don’t notice other issues with it, for example I can navigate the bar using the caret. Normal playback does start at the edge of the piece as expected.

I have tried the potential solutions listed above, but I can get neither my WAV nor my MP3 exports to play. The computer gives a “Windows Media Player encountered a problem while playing the file” message each time.

Win7 OS
No pickup notes.
XML import plays okay via HALion player, just won’t export successfully.

Hi Derrek,

could it be that you were a little bit too impatient? Audio export is faster than real-time, but still, it does take quite some time to export a piece. We currently don’t have a progress bar, yet, so it is not obvious to the user, when export is done.
After you invoke export, you can try to change modes, e.g. from Write to Play mode. Only if Dorico really changes mode, then the export is done. Or you could have a look at the HALion window. During export you will see the numbers left to the instruments blinking as MIDI data arrives. When that stops, export is done.
One more remark, while export is taking place, don’t fiddle around in the HALion window (e.g. playing the on-screen keyboard) as that will also get recorded into the export file.


Thank you for the quick response. I suspected the export would take time, so I watched the file size. When I call the export and then monitor the file folder, the file name appears with a size of zero KB. I do nothing until that changes and stabilizes (in my case around 2-3MB). Only then do I try to double-click the file, but it still gives me the Windows Player error message. So I don’t think trying to play the file too soon is the problem in this case.


would you then please do the following:

  • Create a new Piano project and write let’s say a dozen notes.
  • Press play and make sure that sound comes out
  • Export the piece to a Wave file
  • Zip up the Wave file and the corresponding Dorico project and post it here

Then I can have a look and see what might be wrong.


Then I can have a look at the file

Here you go. Thanks for looking into this. (905 KB)

Hi Derrek,

I unzipped the file you posted and the contained file plays back fine with me in Media Player. Is maybe your Media Player somehow screwed? Maybe worth trying with some other player, e.g. VLC (open source, free download).


You are correct; the file played fine in Quicktime. That’s the first time Windows Player has given me trouble. I’ll have to see if I can figure out why–but that is for me to worry about. Thank you, Ulf, for figuring this out.

I’ve been having the same problem today, and found that my exports WOULD play if I closed Dorico, but not otherwise: they would sit at 0:00.

reporres, it may be that you need to switch off the option in the General Lower-latency ASIO Driver that forces Dorico to take exclusive control of your audio interface.

Hi, I struggle with audio export - flow 1 always export fine, but any subsequent flows may, or may not export well - I often end up with small files with no sound (Quick Time/Mac). Sometimes I can get it to work if I copy the flow I want to export and try again with the copy. It doesn’t matter if I export individual instruments or not. Restarting Dorico to no avail, and I have done maintenance on my eLicencer. Deadline looming.

Welcome to the forum, seven. Can you zip up and attach your project here so that we can take a look and see what might be going on?

Thanks, that’s wonderful. I have enclosed one of the projects that exports silent files from the flow named “For lytting”. Also enclosed are 4 exported audiofile - all silent. Regards, Sven
silent audio (548 KB)