Audio export - .wav extra time added on the end?

Hi

I have exported scores as audio files countless times in the past but, all of a sudden, the .wav files have around 9 seconds of silence added on the end of playback (as though a gap between movements).

I am exporting individual flows from within a large score. I have ensured that, from the PLAY window, that the time between flows is 0secs - but that doesn’t seem to have made any difference.

What am I doing wrong?

Thanks in advance

Pete

This has been asked several times before. The additional 9s are intended and account for a possible long reverb tail.

Thank you ULF. It is just that the files are very large and one of them is just over the 100mb limit for sending to someone that has applied this limit. I thought if I could have the file to the absolute minimum (i.e. no ‘tail’) it might scrape under the limit.

Thanks

We might add an option in the future where the user can adjust the extra tail, but no promise.

I would also like to have the option to adjust this. Besides working as a composer I’m also a teacher. I use Dorico to make tests and worksheets, as I’m sure many other users do too. Sometimes, it’s nice to be able to export audio examples from Dorico, but the extra added time makes the function cumbersome in many cases. Sometimes a chord, a snippet of a melody, or an interval could be only 3-4 seconds long, and having twice as much silence thereafter is unpractical. Not to mention how confusing this must be for the student thinking the example is not finished yet!

Audacity is a free audio program one can use to trim the ends of examples, at least until Dorico comes up with an integrated solution.

There is a hidden value in Dorico’s preferences XML file that you can use to alter this, if you really want to. (It’s not currently exposed because in the fullness of time we expect to provide more per-export options for audio, this among them). First, quit Dorico. Next, find the preferences.xml file in %APPDATA%\Steinberg\Dorico 3.5 (Windows) or /Users/your-username/Library/Application Support/Steinberg/Dorico 3.5 (macOS) and open it in a good text editor, then look for the following lines:

		<audioExportReverbTailSeconds>
			<type>int</type>
			<value>3</value>
		</audioExportReverbTailSeconds>

Change the number in the line to the number of seconds you would like the tail to be. Save the file and restart Dorico, and future audio exports will add that amount of time as a reverb tail.

Thanks Daniel, this is a useful hack!

Great Daniel, thanks for the tip!

Hello Dorico crew,
Indeed would be nice if you add an option to control the extra tail timing, probably somewhere in the Properties panel, or somewhere in the Play Mode. It should be easily accessible and per project based (not global/default setting for every project).
Another idea… we could have two settings about the reverb tail timing one adjustable in the Preferences, which will be the global for every project and another per project setting in the Properties Panel, or Play Mode, which could be activated (in order to overwrite the global one), or deactivated and adjusted.

Thank you in advance! :slight_smile:

Best wishes,
Thurisaz :slight_smile: