Audio export with tempo change


I am struggling to export an 8 bar loop with the tempo changing from 65.5 to 131. Whenever I export the audio comes out a lot longer and not a neat 8 bars and I cannot import it to a new track, which is set at 131. The reason for this is that i don’t want all events to change only a sample that I want getting faster over the 8 bars.

How do I export the 8 bar loop with the tempo change set rather than it changing?? I have tried ticking ‘real-time export’ but still it’s not correct.


If the loop is exactly 8 bars with tempo changes somewhere, it doesn’t mean it will also be 8 bars long when pasting it into a fixed tempo of 131. In that case it will be longer than 8 bars which is completely normal since the tempo change has now been rendered as audio.
If you want it to fit exactly in 8 bars then simply adjust the tempo track where you want to place the loop.

Wait I needed to read that multiple times to understand, do you mean it doesn’t play at the right tempo when importing it into a track with fixed tempo? In that case it means Musical Mode is enabled, and it is automatically adjusting the tempo of the file to follow the project tempo. Please disable Musical Mode for the Event. Actually, if it behaves like this, it’s because the Tempo Definition is already included in the exported file, but the file itself has the proper length, just open it with media player and you’ll see. If you don’t want to include the definition then disable Insert Tempo Definition when exporting, or the global Insert iXML Chunk setting. If there’s no tempo in the file Musical Mode will never turn on automatically upon importing.

I hope this helps.

Screenshots of before export and after import would be helpful.

I’m really struggling with how it can be 8 bars but when exported it is 5.5? I get the time is changing etc but I just want the 8 bar loop with it starting at 65.5 and ending up 131. over the 8 bars and not 5.5.

I also don’t want to have a tempo change live in the track as it changes every event and not just the one I want too.

You’re comparing apples with oranges :grinning:
When working with tempo changes the amount of bars might be steady but the absolute time changes.

Have a look at the time ruler at the right locator mark. I have set up the project similiar to yours: 8 bars, tempo change from 66 to 131. Look at how the time duration for these 8 bar changes when I toggle between the tempo chnage and the steady tempo at 131bpm. From 20.2 seconds to 14.6 seconds.

When working with audio you are working with absolute time, while MIDI refers to bars and beats. Cubase has quite a few good tools on board to let you work with audio as if it would be bars and beats but ultimately that is like make-up on a lady’s face and comes off at the end of the day.

I really appreciate you doing that! Thank you.

It’s so frustrating, I understand what you’re saying and it makes sense but I just don’t like the way it stretches everything else and that’s what I wanted to avoid, also the time factor too as I wanted it neatly in the 8 bars rather than it being 10.5 when bounced! I have tried to bounce the whole project and it still makes it so much longer…

The tempo change track seems to then make everything you put in it make no sense, if I turn off musical mode I can’t then move parts in line! I literally have a headache!

I have now just used the tempo change within the track, it’s just getting the other elements to not stretch

I think where it messes up is the part before Bar 37 on your first screenshot. Did you render that too? Because there’s a tempo change here too, so if you set the project to a fixed tempo these Events will not end where they are supposed to. You need to render everything that is affected by a tempo change before converting the whole thing to a fixed tempo.
In your case you also need to render the Chopped Beats track since it is affected by a tempo change. That’s the reason why the two tracks don’t fit together after setting a fixed tempo.

Try this

  1. Use Save As… to create a copy of the Project for this ‘sidework’
  2. Solo the Audio Track you want to change the Tempo on
  3. Make sure your Tempo Track is Enabled
  4. Export the Audio
  5. In the original Project Import this new Audio into the Pool
  6. Make sure that this Audio has Musical Mode Disabled