Audio files randomly glitch - any ideas?

N6 works perfectly on my main PC but I’ve just bought a laptop as a backup and everything’s behaving very oddly.

If I import WAV files or open old projects it seems like random files are glitching out for no discernible reason. Some files work fine, others are totally glitchy.

I’ve tried importing all sorts of sounds at varying bit-rates, sample rates etc and there doesn’t seem to be a consistent factor in why some files are glitching and others are fine. I believe it’s a symptom of the glitching, but sometimes the wrong sound is being played for the wrong file. For example, if there are 10 sounds of dogs and 10 sounds of cats, the cat sounds might be playing instead of the dog sounds and vice versa if they’re glitching. I would estimate roughly half of all the files I’ve tried are exhibiting this behaviour and there doesn’t seem to be a pattern.

I’m getting EXACTLY the same result with an old version of N4. I’ve tried out Ableton and Reaper on the laptop, and they’re both working perfectly fine.

If anyone has any idea what the hell is going on I’d love to know if there’s a way around this - any help or ideas would be massively appreciated!



Laptop Specs:
Windows 8.1, 120gbSSD, 750gbHDD, 8gbRam, Quad 2.3ghz AMD, 7970M 2GB GFX

The only time I’ve had stuff like this happen was when a drive was corrupted. Not suggesting that’s necessarily what’s going on with you, but… it is what was going on with me.

Good luck!


Hmm cheers to you and Lydiot for the PM - it seems as if copying projects / files onto the laptop HDD and then importing them works fine. I’ve tested a bunch of different things and everything’s opening perfectly. Whilst this is excellent news, it still doesn’t quite explain why projects won’t open correctly from my external HDD… The drive is pretty new, maybe a couple of months old, and the files are all working perfectly everywhere else. Bit of a strange one!

Are you using the laptop to power the external HD? We had a similar problem recently, turned out the computer in question wasn’t supplying enough power to the drive. Problem cleared up when we externally powered it. john.

Nope it’s an externally powered 3TB HDD. I’ve been using it as my backup drive so I haven’t actually been running projects off it before - I just tried loading a project up from it on my main PC and have exactly the same result for some reason. As far as I can see there’s nothing particularly weird about the drive, it’s been working perfectly fine and projects I copied from the drive opened without any sort of glitch or hitch… Quite confused about this one still, bit of an odd situation :stuck_out_tongue:

Had the random white-noise glitch. The issue is if your media is spread across multiple drives or an external drive. Move everything to one drive, preferably internal, and problem disappears. As to why, you’d have to ask Steinberg…

I’m not sure if this applies to your setup, but I’d suggest that you check the connection of your external drive. Is it connected to a USB 3 port?

USB 3 port problems are all over the place recently, and the solution for newer laptops which may come with no USB 2 ports is to use a USB 2 hub between the drive and the laptop. Even your dongle should be connected to a USB 2 port, just to be on the safe side. Most manufacturers claim their USB 3 port is backward compatible with USB 2 devices, but in many cases it’s not true.

Just my 2c.

Good luck.