Audio gets off grid, unable to cut and paste correctly

Hey Guys,
i have this super wired problem. hopefully you know how to fix it.
when i try to cut audio with Quantize the cut is not on the grid.
i tried the with select range, spit tool and i even checked the snap points on the audio.
when i zoom in the spit dont even give me the option to cut it on the grid.
its always jumping a bit to the left or the right.
i tried to disable and enable the snap to zero crossing.
i’ve been working on cubase for 10 years this is the first time that i come across with something like this

have you experienced something like that?

thank you for your time guys

Cubase 8.5 64 bit, Windows 8 64 bit, Intel Xeon CPU E5-1660v3 @ 3.00ghz, 32gb ram, 4 500gb ssd