Audio input not output when track Audio track Monitor is on

Hi, I’m using Windows 8.1, Cubase 8.0.10 Build 427 (64 bit)
Audio interface is M-Audio Fast Track Pro (yeah, I know it’s old :wink: )

When I record from an audio input, I can see the level respond in the Fader in the Inspector and the input channel level meter in the Transport bar, as well as the waveform being displayed on the track itself as I record. I do not hear any sound, though. The Monitor button for the track is activated.

When I turn off the Monitor button and play it back, I hear what I recorded, so I’m pretty sure the output routing is correct.

The output for the track is ‘Stereo Out’, and I triple checked in the VST Connections Output tab that ‘Stereo Out’ is set for Fast Track Pro ASIO, and that Left and Right are set to Device Port Out 1 and Out 2, respectively. And, like I said, it plays back fine, so I don’t think the Stereo Out selection is the issue.

When I go back to Cubase 7.5 I don’t get the problem. When I created a test project in 7.5 and loaded it in 8, I still got the problem.

I’m pretty sure this is some simple audio routing issue in 8, but I don’t know what to try next. So…help???