Audio interface & MIDI Controller won't work with hub

SOMEONE PLEASE HELP ME!!!. Can’t use an Audio interface and MIDI controller at the same time using a powered hub into my iPad Air 2 (using the Apple USB3 or USB2 Camera Adapter kit). Please read and help me if you can:

I am going nuts. I have two different audio interfaces and four different MIDI controllers and two separate powered hubs and no matter what configuration I try, I cannot get one Audio interface and one MIDI controller to work at the same time through a powered hub into my iPad, using an Apple Camera Kit Interface. No matter which audio interface (I have the Steinberg UR 44 and the Zoom U-24)and MIDI controller (I have the M-Audio Axiom Air 32, the Maudio Oxygen 25, and the M-Audio Axiom Air 61 and the Samson Graphite 49 USB keyboard) combination I try, I get the same problem. Each individual device works fine directly into my Lightning USB3 Camera Kit to the iPad Air 2 or through an Anker or Tripp-Lite powered hub alone. I can even plug two MIDI devices into the either USB hub and then into the Lightning USB3 Camera Kit to the iPad and both MIDI devices work.

HOWEVER, as soon as I plug any one MIDI controller in the hub and any ONE Audio interface into the hub at the same time, the MIDI controller cuts out and only the Audio Interface works. This seems to happen with Cubasis as well as other music programs on my iPad Air 2, such as GarageBand. However, when I look up what other people do, I find no one else seems to have a problem plugging an audio interface AND a MIDI controller at the same time into a hub and then into the Camera adapter to the Ipad. For everyone else I can find on the Internet, this configuration seems to work. The only variable is that many mention that they are using a Belkin hub. I am buying a Belkin hub to try that out, but I don’t see why that would make a difference over an Anker or Tripp-Lite hub.

Does anyone have any suggestions? Has anyone come across a similar problem.

PLEEEEZZZEEE I NEED HELP!!! I’M GETTING SO FRUSTRATED AND I HAVE NO IDEA WHO TO CALL SINCE THERE ARE SO MANY DIFFERENT BRANDS OF DEVICES INVOLVED

Hi marsxmarsx

I wrote an comment under :

https://www.steinberg.net/forums/viewtopic.php?f=183&t=116262

best Jan

Hey I was having the Sam issue but didn’t reallt run into the need to solve it until I saw your issue. So you gave me an idea. I’m pretty sure I did the same thing you’re doing, but it worked right away. My keyboard sends midi data and the audio sends to my audio interface and comes out my studio monitors. What I did was, just plug my MIDI keyboard (oxygen 25 blue–its old) and my audio interface (presonus audio box USB) into the same powered hub (DE portable superspeed USB 3.0 hub), which grabs power from an external cable, and then just routed the output of the hub into the camera kit, into the iPad and both are working. If this is what you did, sorry to be of no help, but perhaps it’s my gear that allows me to do it.

Forwarded the topic to the appropriate hardware forum.

Best,
Lars