Audio issue in VL 2.0.21

with last version I started having an issue with my main rehearsal project.
When I open it starts crackling and then the audio engine stops.
If I switch to other projects the issue disappears.
I have Windows 10, audio device: Audient ID4 MKII and use this small project since first versions…
Attached is the project
bajo.vlprj (62.4 KB)

Hi! Having audient too and last fridays 2.0.22 seems to work better. Can u check it first?

Found another issue:
while I´m playing in any project I get the audio engine stopped and the following message:

the issue persists in 2.0.22

… didn’t you, @Felician, said that the latest driver update from Audient ID4 MKII troubled you? Do you, @diegoalejo15, updated the driver, too?

/Michael

Hi @Spork , my problem was only that is thrown away prg start by start but I had different crashes furthermore need to use V1 too. Deleted that part of my post, because VL2 seems to be okay with :slight_smile:

I have latest drivers.
It has to do with multiple stacks and multi processing:
If I have Multi processing enabled and only 1 stack it works fine, if I add a stack it begins to crackle and audio engine stops.
If I have MP disabled and several stacks it also works fine.
Another thing I´ve found is that when I add a stack by defaults it has my instrument Audient input selected but there is no signal, I have to change the input and select again the instrument input to have sound.

I have to add that I have a Ryzen 9 PC so there´s no way I can struggle the CPU with 2 stacks of 1 plugin each.

Will check. What kind of insert fx do you apply in your stacks?

Default is no input, so you probably saved a default Stack which does not connect to the possibly renewed port. Try to save default Stack once it works, will that help?

We can confirm cracles with MP. This is only for the case that multiple stacks use the same input, correct?
We cannot confirm audio stops anymore. Pls try again with the next version (today, presumably). A fix for said crackles will take until next week though, sorry. Until then the workaround is to disable multiprocessing.

Issues persist in v2.0.23

amp sims, maybe an eq or a reverb.

All? audio still stops??

with multi processing enabled yes.

I can confirm similar behavior. From the moment multi-processing introduced, it has not worked at all for me, crashes or freeze like behavior is happening. If disabled everything is fine.

This is the exact same project that I have been using since 1.47 or something. I just tested on 2.0.23

Another note is that I’m on a Ryzen platform as well albeit a Ryzen 7 5800X3D.

After further testing MP, this behavior happens on a Ryzen Desktop, an Intel 11th Gen Laptop and a M1 Macbook Pro.

I will further look at this, but I feel like this is happening if same insert effect is used on more than one layer, even one of the layers is muted. If I clean up a song this way in my production project, it somehow fixes that particular song, but rest of the songs still behave badly.

What I did so far to test it:

  • New clean project, single part, 2 layers, same insert effect, different settings: no problem
  • Changed one of the layers insert effect to another: no problem
  • Added another part, used 2 layers from previous (shared), added another layer with duplicate insert effect (3 layers, 1 insert effect each, 2 of the insert effects are same vst but different settings): no problem initially
  • While playing the second part, tried opening task manager/any other window: everything went haywire.
  • Save and re-open the project: not a crash yet, but audio engine problems immediately.

Further notes:

  • Audio engine problems are different than your typical vst audio cracks and pops.
  • VST Instruments are UADx Spark Plugins / Insert effects are Gatekeeper and Kickstarter (Kickstarter being doubled)
  • So far only tested on Intel Laptop

I tried every step of your descripotion, using UAD instruments and insert plugs that should be similar to yours. No such problems, AMD Ryzen 7 5800X 8-Core tested with UAD Apollo.
Could you try again w/o Kickstarter and Gatekeeper, maybe replace with something similar (“Gate” is pre-installed for instance)?
Also realized that with low latency settings, when changing Parts, there is weird noise, but that happens with both MP enabled or not, and only with UA instruments it seems. In fact during normal play, there are crackles which disappear when MP is enabled.